Centos 7.6.1810 upgrade breaks dual displays

Issues related to hardware problems
loudogse
Posts: 2
Joined: 2018/12/05 21:54:41

Re: Centos 7.6.1810 upgrade breaks dual displays

Post by loudogse » 2018/12/05 22:23:54

I am posting this as my other post is waiting moderation.

This is not a solution as itself but i was able to work around this by installing the gnome-session-wayland-session package and then use the little cog/gear icon to select GNOME wayland before login. The 3 screens seems to be working as expected. Still need to live with a least responsive interface and re-arrange my display settings. And probalby a few more «session-specific» configuration.

i can't blame Wayland for the lag as my setup is pretty much custom-over-minimal and the hardware is getting old but i would still suspect Xorg to be the cause, or at least give a lead.

Hope this helps get your 3 screen back for now, i also hope this helps pin point the problem and resolve the issue. For me Xorg is more effective and wish i could still run it.

chemal
Posts: 444
Joined: 2013/12/08 19:44:49

Re: Centos 7.6.1810 upgrade breaks dual displays

Post by chemal » 2018/12/06 02:09:40

alannz wrote:
2018/12/05 00:14:20
I tried the yum downgrade mentioned in RHBZ 1650634. It only downgraded xorg-x11-server-Xorg.

yum downgrade xorg-x11-drv-nouveau xorg-x11-server-Xorg xorg-x11-drv-qxl.x86_64 xorg-x11-drv-vesa xorg-x11-drv-dummy xorg-x11-drv-v4l xorg-x11-drv-ati xorg-x11-drv-vmware xorg-x11-drv-fbdev xorg-x11-drv-intel.x86_64

Still the same problem.
That's expected. With 7.6 out, this yum downgrade doesnt give you back the 7.5 packages. Xorg has already seen one update in 7.6, and 7.5 rpms are no longer in the repository.

ruizpoveda
Posts: 1
Joined: 2018/12/07 14:52:56

Re: Centos 7.6.1810 upgrade breaks dual displays

Post by ruizpoveda » 2018/12/07 14:54:29

Same here, after upgrading today to Centos 7.6 I can't make my dual monitor work. I have tested both with xfce4 and KDE.

truckertomnz
Posts: 1
Joined: 2018/12/08 04:14:44

Re: Centos 7.6.1810 upgrade breaks dual displays

Post by truckertomnz » 2018/12/08 04:17:26

The latest upgrade broke my desktop so I boot with the old kernel and all is good...broken kernel?

Post Reply