Yum Update Error

General support questions
brishisharma
Posts: 6
Joined: 2010/10/23 07:02:56

Yum Update Error

Post by brishisharma » 2019/01/11 15:01:16

When i try to run yum update, i got the following error. Please help to fix this.

yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* epel: epel.mirror.constant.com
Resolving Dependencies
--> Running transaction check
---> Package iptables.x86_64 0:1.4.21-24.1.el7_5 will be updated
--> Processing Dependency: iptables = 1.4.21-24.1.el7_5 for package: iptables-se rvices-1.4.21-24.1.el7_5.x86_64
---> Package iptables.x86_64 0:1.4.21-28.el7 will be an update
---> Package tzdata.noarch 0:2018g-1.el7 will be updated
---> Package tzdata.noarch 0:2018i-1.el7 will be an update
--> Finished Dependency Resolution
Error: Package: iptables-services-1.4.21-24.1.el7_5.x86_64 (@updates)
Requires: iptables = 1.4.21-24.1.el7_5
Removing: iptables-1.4.21-24.1.el7_5.x86_64 (@updates)
iptables = 1.4.21-24.1.el7_5
Updated By: iptables-1.4.21-28.el7.x86_64 (base)
iptables = 1.4.21-28.el7
Installed: iptables-services-1.4.21-24.1.el7_5.x86_64 (@updates)
iptables = 1.4.16.1
Installed: iptables-services-1.4.21-28.el7.x86_64 (@base)
iptables = 1.4.16.1
You could try using --skip-broken to work around the problem

lightman47
Posts: 844
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: Yum Update Error

Post by lightman47 » 2019/01/11 15:10:57

I want to think this was just a snippet from the actual messages? Somehow, you've got two different iptables installed, and from different repos (base and updates).

My 7.6 iptables are all from the base repo.

User avatar
avij
Forum Moderator
Posts: 2885
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Yum Update Error

Post by avij » 2019/01/11 15:11:52

Most probably you don't have the base and updates repos enabled. Try enabling them.

brishisharma
Posts: 6
Joined: 2010/10/23 07:02:56

Re: Yum Update Error

Post by brishisharma » 2019/01/11 15:22:13

I got this again

yum list iptable*

Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* epel: ewr.edge.kernel.org
236 packages excluded due to repository priority protections
Installed Packages
iptables.x86_64 1.4.21-24.1.el7_5 @updates
iptables-services.x86_64 1.4.21-24.1.el7_5 @updates
iptables-services.x86_64 1.4.21-28.el7 @base
Available Packages
iptables.i686 1.4.21-28.el7 base
iptables.x86_64 1.4.21-28.el7 base
iptables-devel.i686 1.4.21-28.el7 base
iptables-devel.x86_64 1.4.21-28.el7 base
iptables-utils.x86_64 1.4.21-28.el7 base

mashiro2004
Posts: 68
Joined: 2018/12/08 21:46:22
Location: Italy

Re: Yum Update Error

Post by mashiro2004 » 2019/01/11 16:12:49

what version of iptables have you installed now:

rpm -qa iptables

brishisharma
Posts: 6
Joined: 2010/10/23 07:02:56

Re: Yum Update Error

Post by brishisharma » 2019/01/11 16:47:21

mashiro2004 wrote:
2019/01/11 16:12:49
what version of iptables have you installed now:

rpm -qa iptables
iptables.x86_64 1.4.21-24.1.el7_5

User avatar
avij
Forum Moderator
Posts: 2885
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Yum Update Error

Post by avij » 2019/01/11 17:19:02

avij wrote:
2019/01/11 15:11:52
Most probably you don't have the base and updates repos enabled. Try enabling them.

mashiro2004
Posts: 68
Joined: 2018/12/08 21:46:22
Location: Italy

Re: Yum Update Error

Post by mashiro2004 » 2019/01/11 17:20:16

First verify as you ask avij

if repo's are enabled:

try also rpm -qa iptables-services
then yum clean all
and see if you have duplicates:
package-cleanup --dupes

brishisharma
Posts: 6
Joined: 2010/10/23 07:02:56

Re: Yum Update Error

Post by brishisharma » 2019/01/14 01:35:52

mashiro2004 wrote:
2019/01/11 17:20:16
First verify as you ask avij

if repo's are enabled:

try also rpm -qa iptables-services
then yum clean all
and see if you have duplicates:
package-cleanup --dupes
Still not working, I run the below command and output is also given.

rpm -qa iptables-services
iptables-services-1.4.21-28.el7.x86_64
iptables-services-1.4.21-24.1.el7_5.x86_64

package-cleanup --dupes
Loaded plugins: fastestmirror, priorities
iptables-services-1.4.21-28.el7.x86_64
iptables-services-1.4.21-24.1.el7_5.x86_64
flex-2.5.37-3.el7.x86_64
flex-2.5.37-6.el7.x86_64
net-snmp-5.7.2-33.el7_5.2.x86_64
net-snmp-5.7.2-37.el7.x86_64
libquadmath-4.8.5-28.el7_5.1.x86_64
libquadmath-4.8.5-36.el7.x86_64
bind-9.9.4-61.el7.x86_64
bind-9.9.4-61.el7_5.1.x86_64
bind-9.9.4-72.el7.x86_64
php-fpm-5.4.16-45.el7.x86_64
php-fpm-5.4.16-46.el7.x86_64
firewalld-0.5.3-5.el7.noarch
firewalld-0.4.4.4-15.el7_5.noarch
tuned-2.9.0-1.el7_5.2.noarch
tuned-2.10.0-6.el7.noarch
gcc-gfortran-4.8.5-36.el7.x86_64
gcc-gfortran-4.8.5-28.el7_5.1.x86_64
bison-3.0.4-1.el7.x86_64
bison-3.0.4-2.el7.x86_64
cloud-init-0.7.9-24.el7.centos.1.x86_64
cloud-init-18.2-1.el7.centos.1.x86_64
dovecot-2.2.36-3.el7.x86_64
dovecot-2.2.10-8.el7.x86_64
initscripts-9.49.41-1.el7_5.2.x86_64
initscripts-9.49.46-1.el7.x86_64

User avatar
avij
Forum Moderator
Posts: 2885
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Yum Update Error

Post by avij » 2019/01/14 04:06:36

OK, now that you have a list of duplicates you can remove the newer version of each by following the instructions on https://wiki.centos.org/HowTos/Cleaning ... tePackages

In the case of bind, you may need to remove bind-9.9.4-61.el7_5.1.x86_64 as well.

After that is done and package-cleanup --dupes returns nothing, running yum update should get you up-to-date.

Post Reply