Unable to install obs-studio on Centos 7

Issues related to applications and software problems
Post Reply
hellomister
Posts: 2
Joined: 2019/03/17 10:28:50

Unable to install obs-studio on Centos 7

Post by hellomister » 2019/03/17 10:43:52

Hello ,
I am unable to install obs-studio on centos 7. Please find the install error output os-release uname -a
I have installed most of the updates and dependencies still installation is throwing errors ... any idea how to fix this ?

$ more /etc/os-release
NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="7"

$ uname -a
Linux devops11.localdomain 3.10.0-957.5.1.el7.x86_64 #1 SMP Fri Feb 1 14:54:57 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

$ more /etc/centos-release
CentOS Linux release 7.6.1810 (Core)

$ sudo yum install obs-studio-21.1.2-1.el7.nux.x86_64
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: centos.excellmedia.net
* epel: my.fedora.ipserverone.com
* extras: centos.excellmedia.net
* nux-dextop: li.nux.ro
* rpmforge: ftp.cc.uoc.gr
* rpmfusion-free-updates: download1.rpmfusion.org
* updates: centos.excellmedia.net
Resolving Dependencies
--> Running transaction check
---> Package obs-studio.x86_64 0:21.1.2-1.el7.nux will be installed
--> Processing Dependency: obs-studio-libs(x86-64) = 21.1.2-1.el7.nux for package: obs-studio-21.1.2-1.el7.nux.x86_64
--> Processing Dependency: libavutil.so.54(LIBAVUTIL_54)(64bit) for package: obs-studio-21.1.2-1.el7.nux.x86_64
--> Processing Dependency: libavformat.so.56(LIBAVFORMAT_56)(64bit) for package: obs-studio-21.1.2-1.el7.nux.x86_64
--> Processing Dependency: libavcodec.so.56(LIBAVCODEC_56)(64bit) for package: obs-studio-21.1.2-1.el7.nux.x86_64
--> Processing Dependency: libobs.so.0()(64bit) for package: obs-studio-21.1.2-1.el7.nux.x86_64
--> Processing Dependency: libobs-frontend-api.so.0()(64bit) for package: obs-studio-21.1.2-1.el7.nux.x86_64
--> Processing Dependency: libavutil.so.54()(64bit) for package: obs-studio-21.1.2-1.el7.nux.x86_64
--> Processing Dependency: libavformat.so.56()(64bit) for package: obs-studio-21.1.2-1.el7.nux.x86_64
--> Processing Dependency: libavcodec.so.56()(64bit) for package: obs-studio-21.1.2-1.el7.nux.x86_64
--> Running transaction check
---> Package libavcodec56.x86_64 0:2.6.2-2 will be installed
---> Package libavformat56.x86_64 0:2.6.2-2 will be installed
---> Package libavutil54.x86_64 0:2.6.2-2 will be installed
---> Package obs-studio-libs.x86_64 0:21.1.2-1.el7.nux will be installed
--> Processing Dependency: libswscale.so.3(LIBSWSCALE_3)(64bit) for package: obs-studio-libs-21.1.2-1.el7.nux.x86_64
--> Processing Dependency: libswresample.so.1(LIBSWRESAMPLE_1)(64bit) for package: obs-studio-libs-21.1.2-1.el7.nux.x86_64
--> Processing Dependency: libavdevice.so.56(LIBAVDEVICE_56)(64bit) for package: obs-studio-libs-21.1.2-1.el7.nux.x86_64
--> Processing Dependency: libx264.so.142()(64bit) for package: obs-studio-libs-21.1.2-1.el7.nux.x86_64
--> Processing Dependency: libswscale.so.3()(64bit) for package: obs-studio-libs-21.1.2-1.el7.nux.x86_64
--> Processing Dependency: libswresample.so.1()(64bit) for package: obs-studio-libs-21.1.2-1.el7.nux.x86_64
--> Processing Dependency: libavfilter.so.5()(64bit) for package: obs-studio-libs-21.1.2-1.el7.nux.x86_64
--> Processing Dependency: libavdevice.so.56()(64bit) for package: obs-studio-libs-21.1.2-1.el7.nux.x86_64
--> Running transaction check
---> Package libavdevice56.x86_64 0:2.6.2-2 will be installed
---> Package libavfilter5.x86_64 0:2.6.2-2 will be installed
--> Processing Dependency: libpostproc.so.53(LIBPOSTPROC_53)(64bit) for package: libavfilter5-2.6.2-2.x86_64
--> Processing Dependency: libpostproc.so.53()(64bit) for package: libavfilter5-2.6.2-2.x86_64
---> Package libswresample1.x86_64 0:2.6.2-2 will be installed
---> Package libswscale3.x86_64 0:2.6.2-2 will be installed
---> Package obs-studio-libs.x86_64 0:21.1.2-1.el7.nux will be installed
--> Processing Dependency: libx264.so.142()(64bit) for package: obs-studio-libs-21.1.2-1.el7.nux.x86_64
--> Running transaction check
---> Package libpostproc53.x86_64 0:2.6.2-2 will be installed
---> Package obs-studio-libs.x86_64 0:21.1.2-1.el7.nux will be installed
--> Processing Dependency: libx264.so.142()(64bit) for package: obs-studio-libs-21.1.2-1.el7.nux.x86_64
--> Finished Dependency Resolution
Error: Package: obs-studio-libs-21.1.2-1.el7.nux.x86_64 (nux-dextop)
Requires: libx264.so.142()(64bit)
Available: x264-libs-0.142-4.20140423gite260ea5.el7.nux.x86_64 (nux-dextop)
libx264.so.142()(64bit)
Available: x264-libs-0.142-7.20140728gitaf8e768.el7.nux.x86_64 (nux-dextop)
libx264.so.142()(64bit)
Available: x264-libs-0.142-11.20141221git6a301b6.el7.nux.x86_64 (nux-dextop)
libx264.so.142()(64bit)
Installed: x264-libs-0.148-23.20170521gitaaa9aa8.el7.x86_64 (@rpmfusion-free-updates)
~libx264.so.148()(64bit)
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
google-webdesigner-3.0.2.0-1.x86_64 has missing requires of libnss3.so(NSS_3.19.1)

$ sudo yum install nss
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: centos.excellmedia.net
* epel: mirrors.aliyun.com
* extras: centos.excellmedia.net
* nux-dextop: li.nux.ro
* rpmforge: mirror.veriteknik.net.tr
* rpmfusion-free-updates: download1.rpmfusion.org
* updates: centos.excellmedia.net
Package nss-3.36.0-7.1.el7_6.x86_64 already installed and latest version
Nothing to do

$ sudo yum install x264
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: centos.excellmedia.net
* epel: mirrors.aliyun.com
* extras: centos.excellmedia.net
* nux-dextop: li.nux.ro
* rpmforge: mirror.veriteknik.net.tr
* rpmfusion-free-updates: download1.rpmfusion.org
* updates: centos.excellmedia.net
Package x264-0.148-23.20170521gitaaa9aa8.el7.x86_64 already installed and latest version
Nothing to do

User avatar
avij
Forum Moderator
Posts: 2889
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Unable to install obs-studio on Centos 7

Post by avij » 2019/03/17 10:53:50

hellomister wrote:
2019/03/17 10:43:52
Installed: x264-libs-0.148-23.20170521gitaaa9aa8.el7.x86_64 (@rpmfusion-free-updates)
~libx264.so.148()(64bit)
I believe this is your problem. You would need to use x264-libs from nux-dextop.

hellomister
Posts: 2
Joined: 2019/03/17 10:28:50

Re: Unable to install obs-studio on Centos 7

Post by hellomister » 2019/03/17 11:30:57

This is the same version from nux release
should I ask in obsproject community ?

User avatar
avij
Forum Moderator
Posts: 2889
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Unable to install obs-studio on Centos 7

Post by avij » 2019/03/17 13:21:40

hellomister wrote:
2019/03/17 11:30:57
This is the same version from nux release
should I ask in obsproject community ?
Same? I don't know, the version you have installed is x264-libs-0.148-23.20170521gitaaa9aa8.el7.x86_64 and nux-dextop has x264-libs-0.142-11.20141221git6a301b6.el7.nux.x86_64. Does not look the same to me.

Besides, the key point here is not the version of the package but the libraries those packages provide. obs-studio-libs from nux-dextop requires libx264.so.142 and the version of x264-libs you have installed provides libx264.so.148. 142 != 148.

User avatar
TrevorH
Forum Moderator
Posts: 24797
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Unable to install obs-studio on Centos 7

Post by TrevorH » 2019/03/17 13:25:39

Also, if you disable rpmfusion and just leave nux-dextop, EPEL, base and updates enabled then yum install obs-studio works.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply