Network Brother Printer HL-3040CN Installed but no printing

Issues related to hardware problems

Network Brother Printer HL-3040CN Installed but no printing

Postby daniel_c_rib » 2012/02/22 12:40:06

Hi Folks

I am running a DELL laptop with CentOS 6.2 64-bit. At home, I set a network with another Windows WS and a Color Laser Printer Brother HL-3040CN. Printing from the Windows machine is fine.

I used the instructions from Brother Support Site:

http://welcome.solutions.brother.com/bs ... prn1a.html

The only difference is that I didn't use the option --nodeps on rpm command.

By default, the printer is connected by dnssd protocol. The manual says to change it to lpd. I tried both protocol unsuccessfully.

Here the facts:

1 - Driver Installation successful
2 - Using CUPS Web Interface I successfully modified connection protocol to lpd
3 - Print a test page - it says "Processing since " in CUPS. Also, at the printer Data Indicator turns on. But the status keeps "Ready" and no printing is executed. The strange thing is the Data Indicator keeps on. Normally it receives the data, blinks a couple of times and turn off while it is printing.

Many thanks in advance.
daniel_c_rib
 
Posts: 9
Joined: 2012/02/19 14:55:48
Location: Sao Mateus, ES - Brazil

Re: Network Brother Printer HL-3040CN Installed but no printing

Postby daniel_c_rib » 2012/02/25 02:07:44

It seems nobody uses (or at least has no problem with) this printer.

Just to add some information, I realized that the data is sent to printer but some information that printer sends back to computer is no received which generates the following message at CUPS interface:

"remote host did not respond with command status byte after 300 seconds"

Could this be related to SElinux configuration? I think it is activated in my OS by default but I never change its configurations. Is there something specific for network printers?

Thanks in advance
daniel_c_rib
 
Posts: 9
Joined: 2012/02/19 14:55:48
Location: Sao Mateus, ES - Brazil

Network Brother Printer HL-3040CN Installed but no printing

Postby pschaff » 2012/02/25 22:38:45

I don't know of any SELinux or firewall settings required for network printers. My Brother MFC-7820N Laser just works with the supplied driver. You could try
Code: Select all
setenforce 0
service iptables stop

to temporarily disable one or both for testing.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: Network Brother Printer HL-3040CN Installed but no printing

Postby daniel_c_rib » 2012/03/22 18:30:56

Hello pschaff

I have been busy and didn't try your suggestions right way. I did that today and it works. I just disable SELinux with

setenforce 0

And the printing went on.

for the record, I reported this issue to Brother Helpline. They found this bug only in this Model (HL-3040CN).

Well, I'm not sure this is a bug...

Anyway, let's put this thread in posterity

Cheers
daniel_c_rib
 
Posts: 9
Joined: 2012/02/19 14:55:48
Location: Sao Mateus, ES - Brazil

Re: Network Brother Printer HL-3040CN Installed but no printing

Postby pschaff » 2012/03/22 20:39:09

That's not a permanent or recommended solution. For one thing, it will not survive a reboot, and for another, disabling SELinux security features is undesirable. Even if there is a bug that is bothering SELinux is should be possible to create a policy rule to handle it. See the Wiki SELinux articles for some guidance, and provide details if you run into problems.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 6 - Hardware Support

Who is online

Users browsing this forum: No registered users and 0 guests