[RESOLVED] Installation Issue Wireless LAN card TrendNet TEW-423PI in Centos 6.2

Issues related to hardware problems

[RESOLVED] Installation Issue Wireless LAN card TrendNet TEW-423PI in Centos 6.2

Postby mystirious » 2012/05/02 15:50:41

I have installed Centos 6.2 but need help installing TrendNet TEW-423PI wireless adapter here is the output of lspci -v | egrep ethernet

05:02.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5782 Gigabit Ethernet (rev 03)

05:09.0 Ethernet controller: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless (rev 03)
mystirious
 
Posts: 4
Joined: 2012/04/19 10:29:40

Re: Installation Issue Wireless LAN card TrendNet TEW-423PI in Centos 6.2

Postby Aquazone » 2012/05/02 19:25:56

And what exactly is your problem?

Linux drivers are officially available by Broadcom.

And here is an idea about how to install the wireless driver.

It's for debian based systems but I think you can adapt it to work on CentOS.
Aquazone
 
Posts: 24
Joined: 2012/03/09 14:33:02

[RESOLVED] Installation Issue Wireless LAN card TrendNet TEW

Postby gerald_clark » 2012/05/02 19:40:23

better is to install drivers from elrepo.org
http://elrepo.org/tiki/tiki-index.php

The FAQ has instructions for identifying the correct driver.
gerald_clark
 
Posts: 7166
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Installation Issue Wireless LAN card TrendNet TEW-423PI in Centos 6.2

Postby Crunch » 2012/05/02 20:09:58

also if you run lspci -vnn|grep -i ether

this will give you the XXXX:YYYY id

Essentially, you should have the above module loaded. If you go to http://elrepo.org/tiki/DeviceIDs and do a ctrl-F for find and search for XXXX:YYYY you should find your module. the of the module will appear as .ko on the page. You can use XXXX:YYYYas a lookup key for .

this will tell you exactly which module you should have loaded.

do lsmod |grep to see if the module is loaded. If it is not, try loading with modprobe . If it is missing, install the package for that module from elrepo. This should get you up.
Crunch
 
Posts: 101
Joined: 2012/04/02 11:24:46

Re: Installation Issue Wireless LAN card TrendNet TEW-423PI in Centos 6.2

Postby mystirious » 2012/05/03 13:07:04

Thank you for your reply, when I run lspci -vnn | grep -i ether

05:09.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless [11ab:1faa] (rev 03)

so this is the id 11ab:1faa] and when I checked it into http://elrepo.org/tiki/DeviceIDs It was not listed there

am trying to install trendnet wireless lan card in my centos 6.2
mystirious
 
Posts: 4
Joined: 2012/04/19 10:29:40

Re: Installation Issue Wireless LAN card TrendNet TEW-423PI in Centos 6.2

Postby Crunch » 2012/05/03 13:48:06

there doesn't appear to be a readily available linux driver for that device. You can probably get it working with some to a lot of effort. The best I can suggest is getting a device with more support or googleing that device id
Crunch
 
Posts: 101
Joined: 2012/04/02 11:24:46

Re: Installation Issue Wireless LAN card TrendNet TEW-423PI in Centos 6.2

Postby mystirious » 2012/05/04 13:17:36

Dear All,
I really appreciate your help and time, Crunch you are right, the driver for this wireless LAN card is not readily available so I changed the wireless LAN Card and plugged in D-Link DWL-G520 and I was amazed that when I started the computer Centos 6.2 it automatically deducted this Card and I had to do nothing.
mystirious
 
Posts: 4
Joined: 2012/04/19 10:29:40

Re: Installation Issue Wireless LAN card TrendNet TEW-423PI in Centos 6.2

Postby pschaff » 2012/05/04 19:42:35

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

Please let us know if you now consider the issue resolved.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: Installation Issue Wireless LAN card TrendNet TEW-423PI in Centos 6.2

Postby Crunch » 2012/05/05 03:32:08

mystirious wrote:
Dear All,
I really appreciate your help and time, Crunch you are right, the driver for this wireless LAN card is not readily available so I changed the wireless LAN Card and plugged in D-Link DWL-G520 and I was amazed that when I started the computer Centos 6.2 it automatically deducted this Card and I had to do nothing.


Yes, that difficulty doesn't happen too often. You might look at the hw compat list next time you're looking for hardware. http://wiki.centos.org/AdditionalResources/HardwareList . It isn't comprehensive but a good start. The upstream compat list is also relevant. https://hardware.redhat.com/ .

Also, please do, if you feel so, mark the post resolved as Phil asks.

Anyway, I hope it goes well.
Crunch
 
Posts: 101
Joined: 2012/04/02 11:24:46

Re: Installation Issue Wireless LAN card TrendNet TEW-423PI in Centos 6.2(Resolved)

Postby mystirious » 2012/05/05 09:31:09

OK. I am marking it as resolved.
mystirious
 
Posts: 4
Joined: 2012/04/19 10:29:40

Next

Return to CentOS 6 - Hardware Support

Who is online

Users browsing this forum: No registered users and 1 guest