[SOLVED] Centos 6.4 x86_64 - nvidia G84 [Quadro FX 1700]

Issues related to hardware problems

[SOLVED] Centos 6.4 x86_64 - nvidia G84 [Quadro FX 1700]

Postby sevendogzero » 2013/04/07 20:02:20

Installed subject OS on a Dell T3400. Install went fine.

Wanted to have Desktop Effects if possible. Dialog Box error indicates 3D graphics not available

Here's my system
00:00.0 "Host bridge" "Intel Corporation" "82X38/X48 Express DRAM Controller" "Dell" "Device 0214"
00:01.0 "PCI bridge" "Intel Corporation" "82X38/X48 Express Host-Primary PCI Express Bridge" "" ""
00:06.0 "PCI bridge" "Intel Corporation" "82X38/X48 Express Host-Secondary PCI Express Bridge" "" ""
00:1a.0 "USB controller" "Intel Corporation" "82801I (ICH9 Family) USB UHCI Controller #4" -r02 "Dell" "Device 0214"
00:1a.1 "USB controller" "Intel Corporation" "82801I (ICH9 Family) USB UHCI Controller #5" -r02 "Dell" "Device 0214"
00:1a.2 "USB controller" "Intel Corporation" "82801I (ICH9 Family) USB UHCI Controller #6" -r02 "Dell" "Device 0214"
00:1a.7 "USB controller" "Intel Corporation" "82801I (ICH9 Family) USB2 EHCI Controller #2" -r02 -p20 "Dell" "Device 0214"
00:1b.0 "Audio device" "Intel Corporation" "82801I (ICH9 Family) HD Audio Controller" -r02 "Dell" "Device 0214"
00:1c.0 "PCI bridge" "Intel Corporation" "82801I (ICH9 Family) PCI Express Port 1" -r02 "" ""
00:1c.5 "PCI bridge" "Intel Corporation" "82801I (ICH9 Family) PCI Express Port 6" -r02 "" ""
00:1d.0 "USB controller" "Intel Corporation" "82801I (ICH9 Family) USB UHCI Controller #1" -r02 "Dell" "Device 0214"
00:1d.1 "USB controller" "Intel Corporation" "82801I (ICH9 Family) USB UHCI Controller #2" -r02 "Dell" "Device 0214"
00:1d.2 "USB controller" "Intel Corporation" "82801I (ICH9 Family) USB UHCI Controller #3" -r02 "Dell" "Device 0214"
00:1d.7 "USB controller" "Intel Corporation" "82801I (ICH9 Family) USB2 EHCI Controller #1" -r02 -p20 "Dell" "Device 0214"
00:1e.0 "PCI bridge" "Intel Corporation" "82801 PCI Bridge" -r92 -p01 "" ""
00:1f.0 "ISA bridge" "Intel Corporation" "82801IR (ICH9R) LPC Interface Controller" -r02 "" ""
00:1f.2 "IDE interface" "Intel Corporation" "82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA Controller [IDE mode]" -r02 -p8f "Dell" "Device 0214"
00:1f.3 "SMBus" "Intel Corporation" "82801I (ICH9 Family) SMBus Controller" -r02 "Dell" "Device 0214"
00:1f.5 "IDE interface" "Intel Corporation" "82801I (ICH9 Family) 2 port SATA Controller [IDE mode]" -r02 -p85 "Dell" "Device 0214"
01:00.0 "VGA compatible controller" "NVIDIA Corporation" "G84 [Quadro FX 1700]" -ra1 "NVIDIA Corporation" "Device 049a"
04:00.0 "Ethernet controller" "Broadcom Corporation" "NetXtreme BCM5754 Gigabit Ethernet PCI Express" -r02 "Dell" "Precision T3400"

Is there a better driver I can use to fully support this video card?
sevendogzero
 
Posts: 2
Joined: 2013/04/07 19:38:00

[SOLVED] Centos 6.4 x86_64 - nvidia G84 [Quadro FX 1700]

Postby TrevorH » 2013/04/07 20:24:12

Google for ELRepo and install the release package for that to make their packages available. One of the packages there is called nvidia-detect which will identify your chipset and recommend a driver package to use.
User avatar
TrevorH
Forum Moderator
 
Posts: 9166
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: [SOLVED] Centos 6.4 x86_64 - nvidia G84 [Quadro FX 1700]

Postby sevendogzero » 2013/04/07 21:03:28

To TrevorH. That did it. I was a little nervous. Thanks for the hints

These are the steps I took as root in a terminal window.
1. Per ELRepo guide.
rpm --import http://elrepo.org/RPM-GPG-KEY-elrepo.org

2. Per ELRepo guide. To install ELRepo for RHEL-6, SL-6 or CentOS-6:
rpm -Uvh http://elrepo.org/elrepo-release-6-5.el ... noarch.rpm

3. Per TrevorH suggestion.
yum install nvidia-detect

After install typed the following
# nvidia-detect
Probing for supported NVIDIA devices...
[10de:040f] NVIDIA Corporation G84 [Quadro FX 1700]
This device requires the current 310.40 NVIDIA driver (kmod-nvidia). <-Note (kmod-nvidia)

4. Install the package
yum install kmod-nvidia

reboot and problem solved
sevendogzero
 
Posts: 2
Joined: 2013/04/07 19:38:00


Return to CentOS 6 - Hardware Support

Who is online

Users browsing this forum: No registered users and 1 guest