DHCP server assigns IP, but cant connect to Internet

Issues related to configuring your network

DHCP server assigns IP, but cant connect to Internet

Postby dehydratedpaani » 2012/08/17 16:03:43

Hey guys,

I have Cento OS 6 guest running on a fedora host. I have a bridge=br0 on host. IP is assigned to each interface on host(1 total) and guest(2 total). I have 2 interfaces, eth0 and eth1, on guest.

Host can connect to the Internet but cannot ping IPs assigned to eth0/eth1. But guest cannot connect to the Internet but can ping host bridge.

I have disabled NetworkManager on both guest and host.

Host p128p1(eth0) config:

Code: Select all
DEVICE=p128p1
HWADDR=6C:62:6D:E0:ED:47
TYPE=Ethernet
ONBOOT=yes
BRIDGE=br0


Code: Select all
DEVICE=br0
BOOTPROTO=dhcp
TYPE=Bridge
ONBOOT=yes
DELAY=0


Guest eth0/eth1 config:
Code: Select all
DEVICE=eth0
HWADDR=52:54:00:A4:09:CF
TYPE=Ethernet
ONBOOT=yes
BOOTPROTO=dhcp


Code: Select all
DEVICE=eth1
HWADDR=52:54:00:26:8a:79
TYPE=Ethernet
ONBOOT=yes
BOOTPROTO=dhcp


Cant anyone please help?
dehydratedpaani
 
Posts: 1
Joined: 2012/08/17 15:36:27

DHCP server assigns IP, but cant connect to Internet

Postby jlehtone » 2012/08/19 13:37:14

Cant anyone please help?

No. Not with insufficient details.

You do have a bridge in the host, but how is the VM coupled in?
Why do you have two interfaces on the VM?

How are routes on the host when the VM is up?
How are routes on the guest?


You could make use of the 'getinfo.sh' script.
User avatar
jlehtone
 
Posts: 1431
Joined: 2007/12/11 08:17:33
Location: Finland


Return to CentOS 6 - Networking Support

Who is online

Users browsing this forum: No registered users and 3 guests