Joining to AD successful, but unable to login via domain credentials with CentOS 6.3 + 2k8 R2

Issues related to configuring your network

Joining to AD successful, but unable to login via domain cre

Postby Nebby » 2012/10/19 13:41:30

Hello all,

I've followed the Red Hat "Integrating Red Hat Enterprise Linux 6 with Active Directory" document to configure my CentOS 6.3 workstation to join to the 2008 R2 server Active Directory domain. To be more specific, the "6.2 Configuration 2 – Samba/Winbind (idmap_ad)" setup is what I've attempted to implement. I've gotten as far as running the net join command with a successful join to domain response, but I am completely unable to login using domain credentials at all. I've tried via su - , login via ssh, nor logging in via standard GUI, all attempts fail fail with an authentication failure or unknown user. Checking /var/log/messages and /var/log/secure only shows that the user does not exist, but I don't see any hits on pam_winbind (but I'm not sure if I should be seeing any).

Running wbinfo -u and wbinfo -g both work properly and list the groups and users in AD and I am able to generate a kerberos ticket via kinit and verify them with klist. I'm completely at a loss as to why this system is not allowing me to login using a domain credential.

What really has me confused is that I followed the same procedure on another machine and it does work properly, but checking the config files /etc/krb5.conf /etc/samba/smb.conf /etc/pam.d/passwordd-auth and /etc/pam.d/system-auth all are identical; so any help with how to trouble shoot this issue would be greatly appreciated!

Thank you for your time and help!
Nebby
 
Posts: 1
Joined: 2012/10/19 13:21:19

Re: Joining to AD successful, but unable to login via domain credentials with CentOS 6.3 + 2k8 R2

Postby flyaway » 2012/10/24 08:30:21

Hi,

have you tried logging in with your domain-username in the "username@domain.com" format? This should work, if wbinfo shows the correct connection to the AD.

Good luck
flyaway
 
Posts: 1
Joined: 2012/10/24 06:53:40


Return to CentOS 6 - Networking Support

Who is online

Users browsing this forum: No registered users and 5 guests