activating em2

Issues related to configuring your network

activating em2

Postby bhoule » 2012/12/10 21:17:59

I have a Dell PE410 with iDRAC and UEFI/BIOS. iDRAC is active with LOM failover (but UEFI Unified Server Configurator was not configured with an IP). I booted & installed 6.3. eth0 (er um 'em1') was active at the time, and so network-scripts/ifcfg-em1 was created during the install process.

After the fact, I now want to activate em2. I have something plugged in and the link light is active. However, even with rebooting, the ifcfg-em2 script was not created. I created manually by copying from em1 and making appropriate mods. Still, "ifconfig" only reports em1 and loopback. If I query em2 via ifconfig, it doesn't complain that the device is invalid, but neither does it show as UP and with an IP.

em2 Link encap:Ethernet HWaddr 78:2B:CB:5A:DE:1D
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:48 Memory:d8000000-d8012800

Boot messages indicate em2 is being handled exactly the same as em1:

Dec 10 12:26:41 centhost kernel: bnx2 0000:01:00.1: em2: using MSIX
Dec 10 12:26:41 centhost kernel: ADDRCONF(NETDEV_UP): em2: link is not ready
Dec 10 12:26:43 centhost kernel: bnx2 0000:01:00.1: em2: NIC Copper Link is Up, 1000 Mbps full duplex, receive & transmit flow control ON
Dec 10 12:26:43 centhost kernel: ADDRCONF(NETDEV_CHANGE): em2: link becomes ready
Dec 10 12:26:45 centhost avahi-daemon[2306]: Registering new address record for fe80::7a2b:cbff:fe5a:de1d on em2.*.
Dec 10 12:33:00 centhost kernel: udev: renamed network interface eth1 to em2
Dec 10 12:33:00 centhost kernel: udev: renamed network interface eth0 to em1
Dec 10 12:33:00 centhost kernel: bnx2 0000:01:00.0: em1: using MSIX
Dec 10 12:33:00 centhost kernel: ADDRCONF(NETDEV_UP): em1: link is not ready
Dec 10 12:33:00 centhost kernel: bnx2 0000:01:00.0: em1: NIC Copper Link is Up, 1000 Mbps full duplex, receive & transmit flow control ON
Dec 10 12:33:00 centhost kernel: ADDRCONF(NETDEV_CHANGE): em1: link becomes ready
Dec 10 12:33:01 centhost avahi-daemon[2356]: Registering new address record for fe80::7a2b:cbff:fe5a:de1c on em1.*.
Dec 10 12:33:01 centhost avahi-daemon[2356]: Registering new address record for XX.XX.XX.XX on em1.IPv4.
Dec 10 12:33:01 centhost avahi-daemon[2356]: Registering new address record for YY.YY.YY.YY on em1.IPv4.

What additional steps will activate the interface, and by that I mean showing as UP and with the correct IP within ifconfig?
bhoule
 
Posts: 5
Joined: 2012/04/19 19:39:38

Re: activating em2

Postby bhoule » 2012/12/10 23:09:12

Persistence pays off. I forced via "ifcfg em2 add ip.ip.ip.ip/mask". First time thru got something along the lines (from memory) "pctrl: no process to kill", but it worked and has stayed across reboots. Not sure why the manual creation was necessary, but crisis over...
bhoule
 
Posts: 5
Joined: 2012/04/19 19:39:38


Return to CentOS 6 - Networking Support

Who is online

Users browsing this forum: Greg_E and 2 guests