Network service performing too much slow,CentOS 6.4

Issues related to configuring your network

Network service performing too much slow,CentOS 6.4

Postby romanepo » 2013/07/09 10:19:11

Hi,
I install centos 6.4 and install single physical LAN interface card.I add 200 virtual interface for use 200 ip.when i restart network service than it takes 15-30 minute.That causes i delete all virtual interface than it performing fast.When i restart server than it same condition performing too much slow with 200 virtual interface.It occur serious problem.Why and how to resolve this issue.

Best Regards
Roman
romanepo
 
Posts: 11
Joined: 2013/02/03 12:07:24

Re: Network service performing too much slow,CentOS 6.4

Postby simon_matthews » 2013/07/09 15:45:16

Why do you need 200 virtual interfaces? You can set multiple IP addresses on the same interface.
simon_matthews
 
Posts: 315
Joined: 2012/09/15 21:06:54

Re: Network service performing too much slow,CentOS 6.4

Postby robfico » 2013/07/11 03:30:09

We see the same thing with many IPs set as eth0:##. A "service network restart" can take 5 minutes with only 90 virtual IPs assigned. We removed ntpd rpm, installed latest ntp, used "-L" switch, but still it takes minutes to restart fully. With centOS 5, the restart takes 5 seconds with 90 IPs assigned.

Certainly seems like a bug...
robfico
 
Posts: 1
Joined: 2013/07/11 03:26:33

Re: Network service performing too much slow,CentOS 6.4

Postby simon_matthews » 2013/07/11 05:55:04

There appear to be some small changes between CentOS 5 and CentOS 6 in the scripts that bring up interfaces, related to detecting duplicate IP addresses on the network. Perhaps the change in this process is responsible for the delay.

You could probably try tweaking the script in /etc/sysconfig/network-scripts/ifup-eth . Look for the use of arping. Do this at your own risk!

Instead of bringing up 200 IP addresses, it might be possible to fake the IP addresses with some clever use of arp and iptables settings.
simon_matthews
 
Posts: 315
Joined: 2012/09/15 21:06:54

Re: Network service performing too much slow,CentOS 6.4

Postby TrevorH » 2013/07/11 07:39:42

There's a parameter that can be used in ifcfg-* to stop it from using arping. See /usr/share/doc/initscripts-*/sysconfig.txt for details
User avatar
TrevorH
Forum Moderator
 
Posts: 9098
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Network service performing too much slow,CentOS 6.4

Postby romanepo » 2013/07/16 09:06:25

Hi,
I check every thing but still now same problem.How to trace this problem and i want to resolve this issue.Its takes too-much time when i restart network service that causes my all service down 20-30 minutes.

B/Regard
Roman Epo
romanepo
 
Posts: 11
Joined: 2013/02/03 12:07:24

Re: Network service performing too much slow,CentOS 6.4

Postby simon_matthews » 2013/07/16 15:09:56

Did you set "ARPCHECK=no" in your interface configuration files?
simon_matthews
 
Posts: 315
Joined: 2012/09/15 21:06:54

Re: Network service performing too much slow,CentOS 6.4

Postby romanepo » 2013/07/19 19:02:32

Yes ,I add this root interface eth0 "ARPCHECK=no" ,but it still same problem need 15-30 minute,eth0 configuration
DEVICE=eth0
HWADDR=xxxxxx
TYPE=Ethernet
UUID=e7a6cc4b-00d3
ONBOOT=yes
NM_CONTROLLED=yes
BOOTPROTO=static
ARPCHECK=no
IPADDR=xxxxxxxxxxx
NETMASK=xxxxxxxxxxxx
GATEWAY=xxxxxxxxxxx
DNS1=8.8.8.8
DNS2=4.2.2.1
and all virtual Ethernet configuration
DEVICE=eth0:1
BOOTPROTO=static
IPADDR=66.221.158.160
NETMASK=255.255.255.255
ONPARENT=YES

Is it correct?
romanepo
 
Posts: 11
Joined: 2013/02/03 12:07:24

Network service performing too much slow,CentOS 6.4

Postby gerald_clark » 2013/07/19 19:14:30

You have NM_CONTROLLED=yes
Try NOT using NetworkManager.
gerald_clark
 
Posts: 7164
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA


Return to CentOS 6 - Networking Support

Who is online

Users browsing this forum: No registered users and 2 guests