16:00:11 <dcavalca> #startmeeting Hyperscale SIG
16:00:11 <centbot> Meeting started Wed Jul 21 16:00:11 2021 UTC. The chair is dcavalca. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:11 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:20 <dcavalca> #chair dcavalca jvreeland
16:00:20 <centbot> Current chairs: dcavalca jvreeland
16:00:25 <dcavalca> morning folks
16:01:53 <michel-slm> morning!
16:02:28 <dcavalca> let's get started
16:02:34 <dcavalca> #topic Followups
16:03:10 <dcavalca> #info updated workstation spin: https://lists.centos.org/pipermail/centos-devel/2021-July/077156.html
16:03:47 <dcavalca> #info LLVM 12 is now in c8s proper, we have untagged the SIG version
16:04:09 <dcavalca> also, the libvirt bug that came up last time turned out to not affect our backport, so that's nice
16:04:38 <dcavalca> oh and of course I'm reading from the wrong section in the agenda lol
16:04:51 <dcavalca> for actual followups, jvreeland did you hear anything back from devconf.us ?
16:05:31 <jvreeland> @dcavalca Still haven't heard back.
16:05:40 <dcavalca> alright
16:05:56 <dcavalca> on our end, systemd 249 is our so we'll probably get started with that soon
16:06:05 <dcavalca> I also plan to work on the selinux stuff at the hangout later today
16:06:18 <dcavalca> #topic Announcements
16:06:38 <dcavalca> beyond what I wrote above, anybody has any announcements?
16:07:44 <michel-slm> dcavalca: the recent kernel security issue has a related systemd CVE, is ours affected?
16:07:49 <Eighth_Doctor> hey all
16:07:59 <Eighth_Doctor> michel-slm: I believe yes
16:08:02 <dcavalca> michel-slm: uh, I'd missed that
16:08:04 <dcavalca> lovely
16:08:08 <dcavalca> is this the VFS one?
16:08:11 <Eighth_Doctor> yes
16:08:17 <Eighth_Doctor> related to it
16:08:24 <michel-slm> I can find the link, one sec
16:08:31 <Eighth_Doctor> https://bugzilla.redhat.com/show_bug.cgi?id=1984488
16:08:38 <Eighth_Doctor> https://access.redhat.com/security/cve/CVE-2021-33910
16:09:15 <michel> https://blog.qualys.com/vulnerabilities-threat-research/2021/07/20/cve-2021-33910-denial-of-service-stack-exhaustion-in-systemd-pid-1
16:09:26 <dcavalca> yeah, we should double check and patch this in case
16:09:55 <dcavalca> it's a local DoS, so not that big of a deal, but still worth fixing
16:10:44 <dcavalca> I'll check with Anita later today, thanks for surfacing this
16:11:34 <dcavalca> any other announcements?
16:12:03 <Eighth_Doctor> I made a release this week for the Hyperscale (GNOME) Workstation
16:12:15 <Eighth_Doctor> https://lists.centos.org/pipermail/centos-devel/2021-July/077156.html
16:12:39 <michel-slm> already posted :)
16:13:35 <dcavalca> let's move on to
16:13:38 <dcavalca> #topic Tickets
16:13:59 <dcavalca> michel-slm: any update on the powertools stuff for #59 ?
16:16:26 <michel-slm> dcavalca: it was discussed at the last CentOS Stream office hour, and I followed up by posting to the mailing list and bugzilla - but not yet.
16:16:41 <dcavalca> cool
16:16:50 <michel-slm> thread: https://lists.centos.org/pipermail/centos-devel/2021-July/077149.html
16:17:05 <dcavalca> on my side, I filed a couple of tickets for socat and linuxptp
16:17:08 <michel-slm> and bug: https://bugzilla.redhat.com/show_bug.cgi?id=1983216
16:17:25 <dcavalca> socat has a fun bug in https://bugzilla.redhat.com/show_bug.cgi?id=1981308 so I temporarily built one in the SIG to hold us over till that's sorted out
16:17:52 <michel-slm> qq: what does it say about the (lack of) integration testing in CS that we've had to do this several times?
16:17:59 <dcavalca> for linuxptp we have an internal backport with some patches for OCP hardware, I'm trying to get the team to upstream the patches and will move the build to the SIG in the next couple of weeks
16:18:03 * michel-slm looking at dracut
16:18:23 <dcavalca> (PTP = precise time protocol fyi)
16:18:41 <Eighth_Doctor> ohh
16:18:55 <Eighth_Doctor> I was about to ask 😅
16:19:03 <dcavalca> michel-slm: the tests need to exist first :)
16:19:31 <dcavalca> Eighth_Doctor: it's for https://github.com/opencomputeproject/Time-Appliance-Project/tree/master/Time-Card among other things
16:19:33 <michel-slm> dcavalca: yeah. we can probably look into contributing that
16:19:55 <michel-slm> (though that brings the question that's relevant here -- can we use a similar setup to Fedora CI in CBS?)
16:20:07 <dcavalca> at some point we should sit down and look at how the RHEL gating stuff works
16:20:20 <dcavalca> I saw for c9s maintainers are adding gating.yml to most packages
16:20:33 <Eighth_Doctor> we'd need Zuul wired up to CBS for it
16:20:37 <Eighth_Doctor> I don't think they want to do that, though
16:21:12 <dcavalca> didn't bookwar have a talk on this at a recent conference?
16:22:14 <dcavalca> I think it was a Dojo but I can't find it right now
16:23:12 <dcavalca> onto #7, any updates on the kernel stuff jvreeland ?
16:23:36 <dcavalca> we do know that 9 will likely end up with 5.14 fyi
16:23:43 <Eighth_Doctor> yup
16:25:40 <jvreeland> No updates. Was hopping we'd hear back again from rh about the ark stuff. Familiarized myself a bit more with openshift and think i'll finish up the releng stuff this week though.
16:25:41 <Eighth_Doctor> I was thinking that once 5.14 exists in c9s kernel src tree, we could make a branch `<version-release>-hyperscale` to stack our config changes
16:25:58 <Eighth_Doctor> jvreeland: I think you'll need to poke in the email thread to get them to respond
16:27:07 <jvreeland> probably
16:28:24 <jvreeland> Is anyone using this kernel for anything out of curiosity? I've done a few tests but nothing extensive
16:28:56 <dcavalca> it's shipped in the workstation spin that Eighth_Doctor built
16:29:04 <Eighth_Doctor> Yup
16:29:14 <jvreeland> ahhh i didn't realize that, maybe i should put the joysticks back
16:29:17 <Eighth_Doctor> it was the easiest thing to start building, so that's what I did :D
16:29:40 <Eighth_Doctor> also it was surprising how much people really wanted the Hyperscale desktop flavors
16:30:01 <Eighth_Doctor> there's a ton of excitement around Hyperscale + KDE
16:30:26 <Eighth_Doctor> especially among the podcast folks who have been paying attention to Hyperscale
16:32:20 <dcavalca> I think this is all for tickets
16:32:24 <dcavalca> #topic Membership
16:32:41 <dcavalca> any objections to cmurf request in #63 ?
16:33:18 <michel-slm> +1 - no objection
16:33:28 <jvreeland> +1 - no objection
16:33:46 <Eighth_Doctor> +1 no objection
16:34:03 <dcavalca> alright, I'll process this later today then
16:34:19 <dcavalca> #agreed welcome Chris Murphy to the SIG
16:34:29 <dcavalca> this leaves us to
16:34:32 <dcavalca> #topic Misc
16:34:38 <dcavalca> anything else folks want to discuss?
16:34:49 <dcavalca> this is a good time to remind of the VC hangout later today
16:34:54 <Eighth_Doctor> Yup!
16:35:04 <Eighth_Doctor> so, rbowen has announced the CFP for the next CentOS Dojo in October
16:35:19 <rbowen> Yep. Just now!
16:35:25 <dcavalca> oh nice, I didn't realize that was out already
16:35:30 <Eighth_Doctor> https://lists.centos.org/pipermail/centos-devel/2021-July/077165.html
16:35:33 <dcavalca> we should probably do an update there
16:35:40 <Eighth_Doctor> yeah
16:35:48 <rbowen> Yay! I was hoping you would.
16:36:05 <dcavalca> I'll also poke malmond in case he wants to talk about CoW again, hopefully we'll have some more progress by then
16:36:10 <Eighth_Doctor> the CFP for Nest with Fedora also ends this Friday
16:36:35 <michel-slm> and speaking of the Workstation spin, GUADEC starts today
16:36:36 <dcavalca> Eighth_Doctor: do you want to do a Dojo talk on the workstation spin specifically?
16:36:36 <Eighth_Doctor> since a lot of what we're doing involves EPEL-y things and Fedora-y things, we might have something to do there
16:36:45 <Eighth_Doctor> dcavalca: yeah
16:37:02 <dcavalca> yeah I've been following guadec on the other monitor :)
16:37:29 <Eighth_Doctor> michel-slm: the RH office hours at GUADEC is in a couple of hours too :)
16:37:33 <dcavalca> I don't have bandwidth to put together something for Nest, but happy to support if you / others want to do a talk there
16:38:02 <Eighth_Doctor> I definitely don't have bandwidth, but if someone else does, that'd be great
16:38:27 <dcavalca> for Dojo, let's aim for a SIG update talk and a spin talk then
16:38:33 <Eighth_Doctor> yup
16:38:38 <dcavalca> I'll put together a proposal for the SIG update one
16:38:43 <Eighth_Doctor> sweet!
16:38:56 <Eighth_Doctor> and next week I'll put together a proposal for the Hyperscale spin
16:39:01 <Eighth_Doctor> I'd like to get the KDE stuff working first :D
16:39:06 <michel-slm> oh wow, just noticed GUADEC has a youtube livestream
16:39:16 <Eighth_Doctor> yup
16:40:10 <dcavalca> anything else?
16:41:23 <Eighth_Doctor> not at this time
16:42:28 <dcavalca> guess we can end early today then
16:42:41 <dcavalca> thank y'all for coming
16:42:46 <dcavalca> #endmeeting