15:00:39 <pjgeorg> #startmeeting Kmods SIG
15:00:39 <centbot> Meeting started Mon Nov 1 15:00:39 2021 UTC. The chair is pjgeorg. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:39 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:11 <billings> sorry, previous meeting ran over
15:01:29 <pjgeorg> Hi, no problem.
15:01:50 <pjgeorg> I'm currently traveling (train). Hope the connection is stable.
15:01:56 <billings> ok.
15:02:17 <billings> My only point of business is that I created the new documentation site, got it added.
15:02:39 <pjgeorg> Already had a look at it. Thanks!
15:02:52 <billings> the only thing we need to do is get the packages listed
15:02:52 <pjgeorg> We'll probably have to add more information, but it is a very good starting point.
15:03:24 <billings> yeah, mostly stole it from our quarterly post and from your documentation
15:04:04 <billings> I was wondering if there was some way we could magically autobuild the packages from pagure and/or cbs, do they export JSON in a way that we could do it client side?
15:04:08 <billings> maybe I'm thinking too much
15:05:36 <pjgeorg> No sure. I definitely want to have a way to automatically rebuild packages on new kernel releases (if required) running on CentOS resources.
15:05:52 <billings> yeah, that's part of the MQTT automation process
15:06:18 <pjgeorg> I sadly haven't had any time to look into it yet.
15:07:00 <billings> ok
15:07:01 <pjgeorg> But having this in place should allow us to automate most of the tasks.
15:07:35 <billings> We'll need someplace to actually host the automation. Maybe even openshift or some k8s location
15:08:47 <pjgeorg> Yes, need to read more about what CentOS infrastructure is offering. I think we talked about it previously, and the answer was that CentOS infra provides services we could use.
15:08:52 <billings> #link https://sigs.centos.org/kmods/
15:09:47 <billings> lets just make that an action
15:10:08 <pjgeorg> #chair pjgeorg billings
15:10:08 <centbot> Current chairs: billings pjgeorg
15:10:54 <pjgeorg> Is it something you want to look into as well or shall I assign the action to me?
15:11:10 <billings> I want to see what kind of ways we can present the package status
15:11:22 <billings> build status
15:11:57 <pjgeorg> OK, then we can split it. I look into how to automate re-builds, you into presenting build status
15:12:10 <billings> sounds good
15:12:39 <pjgeorg> #action pjgeorg Look into automating package rebuilds using CentOS infrastructure
15:13:30 <pjgeorg> #action billings Look into presenting build status in documentation
15:16:01 <billings> I don't have anything else.
15:16:04 <pjgeorg> I plan to promote all packages I currently tagged in -testing to -release in the next days.
15:16:42 <pjgeorg> As this is the first bunch of package we release, shall I announce it on centos-devel?
15:16:53 <billings> Oh, that's a great idea
15:17:12 <billings> should we have a landing page to describe how to disable secure boot, etc.?
15:18:05 <pjgeorg> Is there a generic way to disable secure boot? I thought it depends on your system.
15:18:29 <billings> No, just that we need to tell people that to use these, they'll have to disable secure boot
15:18:44 <billings> that way if someone responds that they tried it and it wouldn't load, we can point to it
15:19:14 <pjgeorg> I can add that info in the announcement. B
15:19:35 <pjgeorg> But, yes, we should add that info to sigs.centos.org/kmods
15:20:26 <pjgeorg> I'll write the announcement and then add all info provided there to the docs.
15:21:48 <billings> sounds good to me
15:22:09 <billings> I have a couple of my packages that I can promte too (kafs)
15:22:27 <billings> which really only matters for el9 anyway, which is hardly production anyway
15:22:56 <pjgeorg> #action pjgeorg Add info about secureboot to docs
15:23:11 <pjgeorg> #action pjgeorg Announce package releases on centos-devel
15:23:48 <pjgeorg> el9 still needs some time to be ready. Especially concerning building kABI kmod packages.
15:24:42 <pjgeorg> We currently list "Stream 8" and "Stream 9" under packages in the docs. How should we call the "non-stream" version here?
15:25:00 <pjgeorg> "Enterprise Linux 8"?
15:25:12 <billings> that dies at the end of December, I'm just going to pretend it doesn't exist
15:25:33 <billings> unless we're building for Rocky/Alma/et al
15:25:46 <pjgeorg> We agreed to provide kmods for RHEL 8/9 once the buildroots are available in CBS.
15:25:55 <billings> OH right
15:26:10 <pjgeorg> But these will be then for RHEL, Alma, Rocky, whatever
15:26:13 <billings> I am not confidant that we'll get those buildroots but yeah, "Enterprise Linux 8"
15:27:23 <pjgeorg> We'll see.
15:27:50 <billings> if anything, we can ask for buildroots built from one of the rebuilds.
15:28:20 <pjgeorg> For reference: https://pagure.io/centos-infra/issue/400
15:29:29 <billings> Anything else? I have a meeting in a minute, but I don't want to leave anything undiscussed.
15:29:33 <pjgeorg> I think bstinson once mentioned that the CentOS Stream Feature Request SIG is looking into it. But my memory might be wrong.
15:29:41 <pjgeorg> Nothing else from my side.
15:29:45 <billings> Ok, thanks
15:30:07 <pjgeorg> Thanks for attending.
15:30:18 <pjgeorg> I'll close the meeting.
15:30:20 <bstinson> adding RHEL buildroots to CBS is still a thing. we're working on getting the right subscriptions wired up so that we can pull that stuff in
15:30:34 <pjgeorg> Thanks for the info!
15:30:42 <billings> oh, great! I've heard otherwise internally but it might have been about a different topic
15:31:09 <billings> thanks all!
15:32:29 <pjgeorg> Leaving the meeting open for a few more minutes in case anyone wants to add anything.
15:43:12 <pjgeorg> #endmeeting