16:09:57 <dcavalca> #startmeeting Hyperscale SIG
16:09:57 <centbot> Meeting started Wed Nov 10 16:09:57 2021 UTC. The chair is dcavalca. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:09:57 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:10:03 <dcavalca> #chair dcavalca jvreeland
16:10:03 <centbot> Current chairs: dcavalca jvreeland
16:10:08 <dcavalca> ok here we go
16:10:24 <dcavalca> sorry everybody for the delay, for some reason my calendar didn't have this set on UTC correctly
16:11:30 <jvreeland> No worries
16:12:07 <dcavalca> let's get started
16:12:08 <dcavalca> #topic Followups
16:12:32 <dcavalca> I've built and tagged updated versions of zstd and lz4
16:12:41 <dcavalca> these are ABI/API compatible and seem to work fine here
16:12:46 <dcavalca> but lemme know if you see any issues
16:13:36 <dcavalca> we've also started picking up again the openssl3 work in preparation of systemd switching
16:13:43 <dcavalca> and by we, I mean Michel
16:13:48 <dcavalca> see epel-devel for details on that
16:13:56 <Eighth_Doctor> hey all
16:14:00 <dcavalca> that's all on my side
16:14:04 <dcavalca> hey Eighth_Doctor
16:14:08 <dcavalca> anybody else has followups?
16:14:13 <Eighth_Doctor> 😆
16:14:57 <Eighth_Doctor> I'm poking and prodding through CentOS Stream 9 stuff
16:15:17 <Eighth_Doctor> most of my CRB requests have been handled now
16:15:24 <dcavalca> yay
16:15:29 <michel-slm> hello!
16:15:33 <dcavalca> I did see quite a few bugs getting updated, so that's nice
16:15:44 <dcavalca> michel-slm: welcome
16:15:45 <Eighth_Doctor> I can at least get everything I've been looking at so far built on x86_64: https://build.opensuse.org/project/show/home:Pharaoh_Atem:CS9EPELDev
16:16:01 <Eighth_Doctor> so now the next step is filing BZes asking for epel9 builds for everything in this list
16:16:20 <dcavalca> is epel9 open for business yet? iirc we were still waiting for s390x to wrap up
16:16:40 <Eighth_Doctor> it's not open yet, but the BZ product version is already available
16:16:58 <Eighth_Doctor> so if someone could help with filing the BZs for this, that'd be great
16:17:14 <Eighth_Doctor> we can have them all set to blocked on epel-packager-sig so that we can track them and help as needed
16:17:25 <dcavalca> oh cool
16:18:29 <dcavalca> this is a good segway into
16:18:34 <dcavalca> #topic Announcement
16:18:46 <michel-slm> is there a way to grab the full list from OBS?
16:18:56 <dcavalca> in case you haven't been following centos-promo, there's some work afoot to prep for the c9s launch
16:19:02 <michel-slm> I'm thinking of eventually automating this, and this is a good place to start
16:19:30 <dcavalca> Eighth_Doctor: it may be worthwhile to do a blog post or something about the OBS stuff
16:19:38 <dcavalca> I suspect most people don't know about it
16:20:00 <Eighth_Doctor> michel-slm: yes, you can query the list of source packages of a project from the OBS API
16:20:38 <Eighth_Doctor> dcavalca: yeah, I think it'd be good to also include the CBS and openSUSE Build Service stuff as part of the CS9 launch
16:21:22 <dcavalca> we can coordinate with rbowen during office hours after this
16:21:37 <dcavalca> iirc there's a git repo where content is being staged for publication
16:21:58 <Eighth_Doctor> michel-slm: https://api.opensuse.org/source/home:Pharaoh_Atem:CS9EPELDev
16:21:58 * rbowen wakes up ...
16:22:04 <michel-slm> Eighth_Doctor++
16:22:25 <michel-slm> Eighth_Doctor: oh, the API endpoint ... requires authentication
16:22:38 <dcavalca> I have one more item on behalf of anitazha, who I suspect is also going to miss this due to the DST snafu
16:22:58 <dcavalca> we've found an intermittent issue in our systemd CI that tracks down to a python 3.6 bug that's exposed by meson
16:23:02 <Eighth_Doctor> michel-slm: https://paste.centos.org/view/3233b764
16:23:16 <dcavalca> this is fixed in python 3.8, so Anita has put together an updated meson package that uses 3.8
16:23:37 <michel-slm> Eighth_Doctor: thanks! yay XML
16:24:10 <Eighth_Doctor> michel-slm: pretty much all of these are just latest rawhide dist-git commits built
16:24:11 <michel-slm> I'll bring it up at today's EPEL meeting and try and get them filed after that
16:24:28 <michel-slm> right, but we have confirmation it at least builds on one platform so that's probably good enough
16:24:33 <dcavalca> https://cbs.centos.org/koji/taskinfo?taskID=2597015 is the updated meson package in case someone wants to try it out
16:24:49 <Eighth_Doctor> except for a couple (minizip1.2, fail2ban)
16:24:52 <dcavalca> and https://paste.centos.org/view/302ee001 are the changes
16:25:19 <michel-slm> so - only a switch to python 3.8
16:25:43 <Eighth_Doctor> dcavalca: python3.8-devel is provided by python38-devel
16:26:01 <Eighth_Doctor> same for python3.8-setuptools being provided by python38-setuptools
16:26:03 <dcavalca> ah, good catch
16:26:36 <Eighth_Doctor> so you could use %python3_version to control the version being used everywhere
16:27:22 <dcavalca> nice, that does look neater
16:27:55 <dcavalca> anything else for announcements?
16:28:15 <Eighth_Doctor> michel-slm: minizip1.2 is an epel-only package, and fail2ban is broken on rhel9 for some reason and I had to customize it to fix the build
16:28:35 <Eighth_Doctor> based on the epel8 package
16:28:58 <Eighth_Doctor> the rest all work from rawhide straight to rhel9
16:29:58 <michel-slm> Eighth_Doctor: so minizip1.2 still needs to be branched anyway, right?
16:30:03 <Eighth_Doctor> yes
16:30:04 <michel-slm> or is it a new package
16:30:09 <Eighth_Doctor> branched
16:30:12 <Eighth_Doctor> just from epel8 instead of rawhide
16:30:20 <michel-slm> and fail2ban needs to be skipped
16:30:39 <michel-slm> it needs a MR in gitlab probably?
16:30:41 <Eighth_Doctor> for now, yes, though we should figure out why the selinux policy module breaks on rhel9
16:30:51 <michel-slm> ugh, lovely
16:30:56 <Eighth_Doctor> PR in pagure
16:31:00 <Eighth_Doctor> src.fedoraproject.org :)
16:31:16 <michel-slm> oh, it's also in EPEL, good
16:31:28 <michel-slm> when you say RHEL9 I thought you meant RHEL9 base
16:31:36 <Eighth_Doctor> I was able to skip it for my PoC work, but we should work with the maintainer to get that fixed for epel9
16:31:39 <michel-slm> well, might as well request a branch the same way then, and fix it later
16:31:51 <Eighth_Doctor> everything I listed are Fedora package eligible for epel9
16:31:58 <Eighth_Doctor> nah
16:32:22 <michel-slm> dcavalca: oh *now* I see the new hyperscale invitation
16:33:04 <dcavalca> yeah I updated it a few minutes ago
16:33:45 <dcavalca> alright, let's move on to
16:33:48 <dcavalca> #topic Tickets
16:34:04 <dcavalca> I spent some time the other week cleaning up issues and tagging things
16:34:14 <dcavalca> so hopefully the tracker is a bit less confusing right now
16:34:34 <dcavalca> jvreeland: any update on the kernel stuff?
16:35:50 <jvreeland> Nope. 5.12 is tagged for 8 and we can’t tag for 9. They easier now that the Perl 5.30 module on 8 stream is gifted
16:36:17 <jvreeland> Well experimental on 8
16:36:52 <jvreeland> *install there was an issue with Perllibs
16:37:12 <dcavalca> sounds good
16:37:20 <dcavalca> for #71, is there anything else we need to do for aarch64?
16:37:47 <jvreeland> Release package. I wrote down what you told me about fixing it but haven’t looked into it
16:38:10 <dcavalca> that's great, because I have no memory of that conversation :)
16:38:45 <dcavalca> I don't see bkircher around, so I'm assuming the qemu stuff is still in progress
16:38:45 <jvreeland> I think it’s down to just poking whoever rebuilds those
16:39:17 <dcavalca> michel-slm: we should figured out a conclusion for #59 (the powertools thing)
16:39:31 <dcavalca> jvreeland: I usually bug carlwgeorge
16:39:49 <michel-slm> dcavalca: ah, fun. I think RH won't turn powertools/crb on by default no matter what
16:40:13 <dcavalca> so we're back to doing it with a script in %post ?
16:40:39 <themayor> Yes afaik, and we asked, it won’t be turned on by default
16:40:41 <michel-slm> and %post is icky and Carl won't build it. I think fix it if people use a Hyperscale image, otherwise hope for the best?
16:41:01 * dcavalca sights
16:41:17 <michel-slm> long, long term solution is to get DNF to be able to use config directories, but if that happens it will take several years to trickle to CS
16:41:53 <Eighth_Doctor> I've got an idea of writing a helper tool to ship in epel-release to solve this
16:41:54 <michel-slm> (I brought it up at a DNF meeting once but... huh, we can check with Matthew if there's any update on that, since I've not been to another meeting since)
16:42:18 <Eighth_Doctor> it'd check whether it's RHEL or clone (for subman stuff) and enable the appropriate CRB/PowerTools repo
16:42:55 <Eighth_Doctor> as long as we don't use DNF itself for it (which would trigger read of rpmdb), then it'd work
16:43:40 <dcavalca> that could work
16:43:45 <michel-slm> Mike Rochefort was digging a bit into this, searching my mail to see if he posted anything recently
16:44:18 <michel-slm> Eighth_Doctor: yeah, that should work. it's also version specific, in CS9 it's crb - so a tool sounds much better than trying to do this in %post or %posttrans anyway
16:44:35 <Eighth_Doctor> since bstinson won't budge on fixing centos-repos, we'll *have* to a script
16:44:37 <michel-slm> how do we get this tool running though - cheat and have installation drop a systemd timer?
16:44:43 <Eighth_Doctor> the tool will be run in %posttrans
16:45:06 <mroche[m]> michel-slm: I haven't done any work regarding CRB besides the checks for runtime dependencies.
16:45:14 <michel-slm> oh, IIRC there's a discussion on splitting out -crb into a separate subpackage too?
16:45:48 <michel-slm> in which case we can just have an override that we can pull if epel-release is installed on centos
16:46:11 <michel-slm> mroche[m]: ack
16:46:53 <dcavalca> alright, let's move over to
16:46:57 <dcavalca> #topic Membership
16:47:12 <dcavalca> themayor: did you want to formally join the SIG ?
16:47:25 <themayor> Yes
16:47:38 <dcavalca> alright, let's do that then
16:47:49 <dcavalca> I'm a +1 on this, does anybody have any objections?
16:48:22 <michel-slm> remind me who themayor is :)
16:48:24 <michel-slm> Carl?
16:48:39 <themayor> Ok so I should probably introduce myself for those who don’t know me
16:48:46 <Eighth_Doctor> +1 from me
16:49:11 <Eighth_Doctor> Jack Aboutboul from AlmaLinux
16:49:18 <michel-slm> oh! +1
16:49:33 <Eighth_Doctor> also the guy who created the original Fedora Ambassadors program, which was the progenitor of Mindshare :)
16:49:36 <themayor> Hey everyone I’m themayor, I originally hail from the land of fedora, former red hatter and no I live in AlmaLinux land as the community manager and tryer of doing good things
16:49:50 <themayor> Indeed
16:49:58 <themayor> And fedora qa engineering
16:49:59 <Eighth_Doctor> but yeah, themayor introduce yourself properly :)
16:50:00 <michel-slm> yeah, the name is very familiar, I just never chatted with Jack on IRC so not familiar with the nick :)
16:52:30 <dcavalca> alright, I think we have agreement here
16:53:04 <dcavalca> #agreed welcome themayor to the hyperscale SIG
16:53:25 <themayor> Thank you very much everyone
16:53:27 <dcavalca> themayor: can you file a ticket on the tracker to sort out onboarding? I'll try to get around it later today
16:53:38 <themayor> Sure will do that as soon as the meeting is done
16:53:43 <dcavalca> perfect, thanks
16:53:56 <dcavalca> this leaves us with a few minutes for
16:53:58 <dcavalca> #topic Misc
16:54:11 <dcavalca> the only remaining thing I had is that Neal and I will be presenting at SC21 next week
16:54:34 <themayor> Is that in person or virtual?
16:54:44 <dcavalca> the conference is in person, we'll be presenting remotely
16:54:52 <dcavalca> https://sc21.supercomputing.org/
16:54:54 <themayor> Cool. I will be at the conference
16:55:01 <dcavalca> sweet
16:55:07 * dcavalca still needs to figure out if we need to register or not
16:57:20 <themayor> If anyone wants to attend in person, I can probably help with that
16:57:23 <themayor> Please ping me
16:57:44 <dcavalca> thanks themayor
16:58:13 <rbowen> You mean you have passes?
16:58:27 <rbowen> I will be there in person, too, FWIW.
16:58:58 <themayor> Yes AlmaLinux has a booth there
16:59:08 <rbowen> Ooh. Excellent. See you next week, then. :)
16:59:13 <themayor> We have passes and can also probably help cover some airfare/hotel if anyone needs it
17:00:24 <dcavalca> alright, that's all the time we have
17:00:34 <dcavalca> hopefully the scheduling for the next one will be less hectic :)
17:00:39 <dcavalca> thanks everyone!
17:00:42 <dcavalca> #endmeeting