16:00:49 <dcavalca> #startmeeting Hyperscale SIG
16:00:49 <centbot> Meeting started Wed Nov 24 16:00:49 2021 UTC. The chair is dcavalca. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:49 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:57 <dcavalca> #chair dcavalca jvreeland
16:00:57 <centbot> Current chairs: dcavalca jvreeland
16:00:59 <dcavalca> morning everyone
16:02:02 * Eighth_Doctor waves
16:02:24 <dcavalca> let's wait a couple of minutes
16:02:35 <dcavalca> not sure how many folks will be around today given that it's turkey week in the US
16:02:56 <Eighth_Doctor> indeed
16:04:07 <dcavalca> let's get started
16:04:09 <dcavalca> #topic Followups
16:04:30 <dcavalca> not much on my end, but Michel has landed openssl3 in epel8
16:04:53 <dcavalca> so we'll be able to keep updating systemd once they switch to the new version
16:05:07 <dcavalca> #info openssl3 is now available in epel8
16:05:35 <themayor> Hello
16:05:38 * themayor waves
16:05:39 <dcavalca> oh also, Eighth_Doctor switched the monthly hangout meeting to zoom
16:05:50 <dcavalca> Eighth_Doctor: did you put up a PR for the centos calendar already?
16:05:57 <Eighth_Doctor> nope
16:06:05 <Eighth_Doctor> I'll do that during my lunchtime today
16:06:14 <dcavalca> #action Eighth_Doctor update monthly VC hangout meeting in the centos calendar
16:06:31 <Eighth_Doctor> I will have to have people ask in #centos-hyperscale:libera.chat for the password each time
16:06:35 <Eighth_Doctor> because I can't get rid of the password :(
16:06:49 <Eighth_Doctor> but otherwise, we should be okay
16:06:50 <arrfab> Eighth_Doctor: for zoom ?
16:06:55 <Eighth_Doctor> yes
16:07:03 <arrfab> if you provide the full link to a zoom meeting the pass is encoded in the url ;-)
16:07:05 <Eighth_Doctor> my account doesn't allow us to disable the password
16:07:15 <Eighth_Doctor> yeah, but I also don't want zoombombers :)
16:07:19 <arrfab> so if you have zoom client it's automatically joigning when clicking on the url
16:07:26 <arrfab> just put a moderation room ?
16:07:33 <dcavalca> Eighth_Doctor: can we approve people to join one by one?
16:07:34 <Eighth_Doctor> I did enable that
16:07:34 <arrfab> so you can accept them
16:07:48 <Eighth_Doctor> I think that's how that works
16:07:59 <dcavalca> yeah that seems better then, embed the password in the URL and approve people
16:08:00 <Eighth_Doctor> people go into the lobby at first, I believe
16:08:18 <Eighth_Doctor> and I think I have to start the room too
16:08:36 <Eighth_Doctor> I've never played with this feature before, so dcavalca you and I should make a test meeting to try it
16:08:40 <dcavalca> yeah that's the downside with zoom, it needs a licensed user to kick off the meeting
16:08:45 <dcavalca> sure thing
16:08:58 <Eighth_Doctor> we'll do that later in the day :)
16:09:18 <dcavalca> anything else for followups?
16:09:42 <Eighth_Doctor> I think EPEL 9 is almost open?
16:10:02 <Eighth_Doctor> I've seen a flurry of crap going on there by carlwgeorge and tdawson
16:10:14 <dcavalca> oh nice
16:10:22 <arrfab> iirc it's still blocked due to lack of s390x infra
16:10:22 <dcavalca> right in time for us to get started with iptables-extra then
16:10:46 <dcavalca> didn't that get resolved last week? I think I saw a message that the mainframe switchover was successful this round
16:10:50 <carlwgeorge> s390x issue is resolved, now just deciding if we launch epel9 at the same time as epel9-next
16:10:52 <carlwgeorge> https://lists.fedoraproject.org/archives/list/epel-devel@lists.fedoraproject.org/thread/NH4CM6MAVUTUH35NDM53PTKCHODSEP6F/
16:10:59 <arrfab> oh, good news then :)
16:11:30 <Eighth_Doctor> I believe we're discussing that today at the EPEL meeting
16:11:38 <Eighth_Doctor> so dcavalca you should probably be there
16:11:54 <carlwgeorge> we'll be picking one of those plans at today's meeting, and announce it in conjunction with the c9s launch promotion
16:11:55 <Eighth_Doctor> I'm going to try to be there too, but I have a work meeting conflict, we'll see if it gets canceled :)
16:12:28 <dcavalca> yeah I'll be there
16:13:11 <dcavalca> alright let's move over to
16:13:15 <dcavalca> #topic Announcements
16:13:30 <dcavalca> reminder that the centos stream 9 launch is gonna happen soon
16:13:52 <dcavalca> so if there's stuff you want to do / align with there it's a good time to get involved
16:14:08 <dcavalca> coordination is happening on the centos-promo list
16:14:14 <Eighth_Doctor> I'd like to see if we can get our Hyperscale content ready for that
16:14:25 <Eighth_Doctor> at least get the basic release repos ready
16:14:46 <dcavalca> agreed, but I don't thing we can tag stuff for 9 yet?
16:14:49 <Eighth_Doctor> Hyperscale 9 is going to be so much more interesting :)
16:14:52 <dcavalca> or at least, last I tried it wouldn't let me
16:14:56 <arrfab> dcavalca: you can
16:15:08 <arrfab> well, I just need to unlock the -release tags, but in theory that can be done now
16:15:30 <dcavalca> ooh nice, yes in that case it'd be great to get our tags unlocked so we can start releasing builds
16:15:31 <arrfab> (in meeting so following/participating in both meetings, one one google meet and here)
16:15:36 <Eighth_Doctor> arrfab: our repos should be mirrored along with the rest of c9s content in mirrormanager
16:15:39 <arrfab> yes
16:15:43 <dcavalca> thanks arrfab, should I file a ticket?
16:16:05 <Eighth_Doctor> once unlocked, I can start populating Hyperscale Workstation content for 9
16:16:48 <Eighth_Doctor> also bring over my libvirt backport :)
16:18:27 <dcavalca> I need to get a systemd build out so I can move forward with c9s validation here
16:20:22 <dcavalca> anything else for announcements?
16:20:46 <Eighth_Doctor> nothing else from me for now
16:20:52 <arrfab> dcavalca: no ticket needed, I'll just process all the el9s-build tags to unlock and just announce on centos-devel
16:21:10 <arrfab> normally Adrian gave me the logic for metalink and mirrormanager based on the location of where SIG content will land
16:21:30 <dcavalca> awesome, thanks again arrfab
16:21:40 <Eighth_Doctor> how about our release packages?
16:21:50 <arrfab> so last step will be the special SIG that Brian discussed on centos-devel so that SIG are autonomous and can just build+push centos-release-* without asking for Johnny to build on the distro builders
16:22:21 <Eighth_Doctor> hmm
16:22:23 <arrfab> bstinson is on pto this week (like a lot of people in USA) but I'd like to see with him about implementations details and wor on this
16:22:42 <Eighth_Doctor> sure, sounds good
16:22:43 <arrfab> Eighth_Doctor: why the "hmm" ?
16:22:45 <arrfab> ah :)
16:22:59 <dcavalca> oh right, we'll need to branch our release package too
16:23:01 <Eighth_Doctor> ideally, Hyperscale can launch with c9s and epel9 together :)
16:23:08 <dcavalca> that'd be ideal
16:23:08 <arrfab> basically the only thing that stream will provide as repo is the .repo for these release files and the rpm gpg key for it
16:23:24 <arrfab> so that people can then "dnf install centos-release-hyperscale-<foo>"
16:23:42 <arrfab> signed from the imported rpm gpg key for that special repo
16:23:55 <arrfab> and then get content from corresponding SIG repo (using the sig dedicated key)
16:24:17 <arrfab> that's the overview but just need to sync one last time with bstinson but seems all pretty straight-forward
16:24:24 <Eighth_Doctor> yay trust inheritance modeling
16:24:26 <arrfab> btw, the plan is also to then provide this for stream8
16:24:29 <Eighth_Doctor> speaking of which...
16:25:08 <Eighth_Doctor> does it make sense to change things for stream8?
16:25:17 <Eighth_Doctor> or is this part of moving it to Fedora MirrorManager?
16:25:22 <arrfab> no
16:25:38 <arrfab> stream8 SIGs will not move to mirrormanager
16:26:20 <arrfab> but what I meant was having the possibility to build+push -release pkgs directly built through cbs, so without asking bstinson, carlwgeorge or hughesjr to do it and then kick a full compose just for that pkg
16:26:26 <Eighth_Doctor> ahhh
16:29:10 <dcavalca> let's move over to
16:29:13 <dcavalca> #topic Tickets
16:29:35 <dcavalca> Eighth_Doctor: iirc there was a systemd thing you'd mentioned last week?
16:29:46 <Eighth_Doctor> yeah
16:30:10 <Eighth_Doctor> it'd be great to have https://bugzilla.redhat.com/show_bug.cgi?id=2025183 resolved in our systemd build for el8 and el9
16:30:31 <Eighth_Doctor> it will resolve some issues with KDE Plasma with systemd user sessions
16:30:56 <dcavalca> that should be fine
16:31:11 <dcavalca> speaking of systemd, anitazha put up some release management docs at https://sigs.centos.org/hyperscale/internal/systemd/
16:31:16 <Eighth_Doctor> I tried to do the backport myself, but there's code conflicts and I didn't know how to deal with those
16:31:38 <dcavalca> Eighth_Doctor: it might be easier to just wait for the next release if that's coming soon
16:31:56 <Eighth_Doctor> fair point
16:32:03 <dcavalca> I'll check and see when that's due, iirc it was pretty close
16:32:06 <Eighth_Doctor> that's probably something anitzha could give us more info on
16:32:09 <Eighth_Doctor> yeah
16:32:53 <dcavalca> I think she's out today but I'll followup next week
16:33:11 <Eighth_Doctor> sounds good
16:33:13 <dcavalca> don't think we had anything else for tickets this round
16:33:28 <Eighth_Doctor> well
16:33:39 <Eighth_Doctor> I wanted to remind us of this: https://git.centos.org/centos/board/issue/67
16:33:54 <Eighth_Doctor> which is related to us bringing the spins and kernel stuff out of experimental phase
16:34:05 <dcavalca> yes, we'll get that discussed on the next board meeting
16:34:12 <dcavalca> there's been some scheduling issues so we missed the last one
16:34:22 <dcavalca> (meaning, the meeting didn't happen at all)
16:34:24 <Eighth_Doctor> I want to highlight that if we can't resolve this such that Hyperscale can deal with secure boot stuff, we'll have to stop using CBS for that
16:34:42 <Eighth_Doctor> and I'm really not sure what we'll do instead
16:34:56 <dcavalca> Eighth_Doctor: if you want to post a summary on that issue, it'd probably help focus the discussion
16:35:06 <Eighth_Doctor> sure
16:35:09 <Eighth_Doctor> I can do that
16:35:32 <dcavalca> thanks
16:36:54 <Eighth_Doctor> I don't have anything else right now
16:37:13 <dcavalca> alright, time for
16:37:18 <dcavalca> #topic Membership
16:37:26 <dcavalca> themayor: we still need to sort out your stuff
16:37:52 <arrfab> if you have news about that SecureBoot ticket, feel free to share later ;-)
16:38:41 <dcavalca> arrfab: for sure, I'm hoping we can get this resolved on the next board meeting one way or the other
16:39:40 <themayor> dcavalca: yes we do. this week is light so its a good time
16:39:59 <dcavalca> themayor: I mostly need your FAS account, the rest we can coordinate in the ticket
16:40:06 <themayor> FAS account is jack
16:40:13 <dcavalca> perfect, thanks
16:41:07 <dcavalca> filed https://pagure.io/centos-sig-hyperscale/sig/issue/82 for tracking
16:41:20 <themayor> thanks!
16:41:43 <dcavalca> I'm also gonna make a membership tag in the tracker while at it
16:42:08 <Eighth_Doctor> themayor: you don't use jaboutboul?
16:42:27 <Eighth_Doctor> that FAS account also exists
16:42:33 <themayor> i think its an alias
16:43:11 <Eighth_Doctor> https://accounts.fedoraproject.org/user/jaboutboul/
16:43:18 <Eighth_Doctor> https://accounts.fedoraproject.org/user/jack/
16:43:32 <Eighth_Doctor> I'm very confused
16:43:59 <Eighth_Doctor> jack redirects to jaboutboul in the wiki
16:44:06 <Eighth_Doctor> but there are two separate accounts in FAS
16:44:34 <dcavalca> ugh ok I'd recommend taking to fedora-aaa and get that sorted out
16:45:22 <dcavalca> jack does look like the one with actual group memberships and stuff
16:45:41 <Eighth_Doctor> yeah
16:45:53 <Eighth_Doctor> which means I've been at-tagging the wrong account for months...
16:46:53 <themayor> oh man. that sucks
16:47:07 <themayor> well i should really receive notifications for both
16:47:24 <Eighth_Doctor> yeah you should probably talk to the fedora accounts folks to get that sorted out
16:47:51 <themayor> i vaguely remember that when the alias was setup it worked as well
16:48:38 <themayor> i will get it sorted out
16:49:01 <Eighth_Doctor> cool
16:50:03 <dcavalca> #topic Misc
16:50:08 <dcavalca> anything else folks want to talk about?
16:51:30 <Eighth_Doctor> I'm currently syncing c9s to Datto's Free Software mirror
16:51:56 <Eighth_Doctor> and I need eye bleach for dealing with the crazy setup :(
16:52:38 <Eighth_Doctor> but I will be filing a ticket shortly to get Datto added to the c9s mirror category in MirrorManager
16:52:58 <dcavalca> it wasn't too bad when I rigged it up on my end
16:53:16 <Eighth_Doctor> well I also discovered our epel mirror was just not running :/
16:53:20 <Eighth_Doctor> so I had to fix that too
16:53:48 <dcavalca> yeah one thing I've noticed is that we need way better monitoring for mirror status
16:54:01 <dcavalca> that's on my list of things to look at eventually
16:54:20 <Eighth_Doctor> I'm probably going to write some basic tooling for doing these mirrors
16:54:30 <Eighth_Doctor> each distro is mirrored completely differently and that drives me nuts
16:54:45 <Eighth_Doctor> (as in, there are completely different scripts for each one :()
16:54:48 <themayor> dcavalca: we just did similar might be able to rope some of our folks in to help
16:55:06 <dcavalca> I'd be down for that
16:55:15 <Eighth_Doctor> indeed
16:55:30 <dcavalca> we manage our mirrors with Chef, and while the cookbooks aren't public yet I could clean them up if there were interest
16:55:43 <dcavalca> not that it's anything special, basically rsync in cron + apache in front of it
16:55:56 <Eighth_Doctor> I don't even have that
16:56:12 <Eighth_Doctor> I'm probably going to write a trivial Python-based service framework for doing basic rsync stuff
16:56:37 <dcavalca> Eighth_Doctor: I may have that already, but I'm not sure how deeply nested it is with our crap
16:56:40 <dcavalca> will check and report back :)
16:56:53 <Eighth_Doctor> ohh that'd be nice
16:57:09 <Eighth_Doctor> also, I hate crontabs so much
16:57:19 <Eighth_Doctor> systemd timers are awesome, crontabs seriously suck
16:57:45 <dcavalca> agreed, but this stuff doesn't run on my infra (mirrors are in IT space here), so not my call
16:57:58 <Eighth_Doctor> yeah
16:58:02 <Eighth_Doctor> I'm complaining about my box :)
17:00:42 <dcavalca> alright, we're out of time
17:00:54 <dcavalca> enjoy the holidays if you celebrate
17:01:04 <dcavalca> and have a good one otherwise
17:01:13 <dcavalca> #endmeeting