16:00:17 <dcavalca> #startmeeting Hyperscale SIG
16:00:17 <centbot> Meeting started Wed Sep 15 16:00:17 2021 UTC. The chair is dcavalca. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:17 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:23 <dcavalca> #chair dcavalca jvreeland
16:00:23 <centbot> Current chairs: dcavalca jvreeland
16:00:27 <dcavalca> morning everyone
16:01:00 <bkircher> good evening :)
16:01:01 <jvreeland> Morning still on vacation so don’t have anything to add today
16:01:52 <dcavalca> eh, I was also off last week
16:02:52 <dcavalca> let's get started
16:02:54 <dcavalca> #topic Followups
16:03:31 <dcavalca> c9s is moving forward, and we can now do builds against it in CBS
16:03:49 <dcavalca> I tested this out with kpatch and it seemed to work fine
16:04:17 <dcavalca> we also got aarch64 added to all our tags, so all packages will build for that too going forward
16:04:30 <dcavalca> jvreeland: fair warning, we'll probably bug you if stuff breaks there :)
16:04:56 <dcavalca> the only other thing I have for followups is that the Dojo schedule is out
16:05:07 <dcavalca> https://wiki.centos.org/Events/Dojo/October2021
16:05:24 <dcavalca> with our usual SIG update talk
16:05:31 <dcavalca> anybody has anything else for followups?
16:06:54 <dcavalca> alright, let's move to
16:06:55 <dcavalca> #topic Announcements
16:07:16 <dcavalca> #info ethtool 5.14 tagged for -release
16:07:36 <dcavalca> the only other thing I had is some news from systemd
16:07:46 <dcavalca> upstream is considering moving to openssl 3.0.0
16:07:57 <dcavalca> which could prove tricky for us, as c8s is on 1.1.1k and unlikely to update
16:08:07 <dcavalca> see https://lists.freedesktop.org/archives/systemd-devel/2021-September/046881.html for more details
16:08:28 <dcavalca> this isn't set in stone yet, but we should get our ducks in a row and figure out what's workable and what's not for us so we can report back
16:08:38 <dcavalca> Eighth_Doctor: ^^ this is also relevant to your interests I suspect
16:10:02 <Eighth_Doctor> hey
16:10:11 <Eighth_Doctor> oh dear, yeah
16:11:37 <Eighth_Doctor> dcavalca: this discussion seems to presume that it's going to happen
16:11:47 <Eighth_Doctor> why do we want to switch to OpenSSL?
16:12:17 <dcavalca> Eighth_Doctor: I'm assuming it'll happen eventually, but feedback from the community will impact the when and the how
16:12:35 <dcavalca> systemd right now has like three different SSL libraries linked in
16:12:54 <dcavalca> they'd like to go down to just one, and after the relicensing OpenSSL becomes the most viable
16:13:12 <dcavalca> (if you haven't followed, OpenSSL 3 is Apache2-licensed now)
16:13:41 <Eighth_Doctor> yeah
16:13:46 <Eighth_Doctor> why not use GnuTLS?
16:13:53 <Eighth_Doctor> that's LGPL and could be used across the board
16:15:37 <dcavalca> they already use gnutls in places and it has a bunch of shortcomings they'd like to move away from
16:15:58 <dcavalca> I forgot the specifics (this was in a long discussion a while ago), but it was a legitimate reason from what I recall
16:16:39 <Eighth_Doctor> and OpenSSL is better? the API is pretty bad...
16:18:52 <dcavalca> yeah... I don't really have a stake in this, but consensus upstream seemed to be towards openssl for the most part
16:19:04 * Eighth_Doctor shrugs
16:19:19 <dcavalca> the other argument (which makes sense to me) is that on minimal systems openssl is very likely to be required already anyways, which may not be the case for other implementations
16:19:45 <Eighth_Doctor> on minimal Debian systems, GnuTLS is what's used, not OpenSSL
16:19:47 <Eighth_Doctor> so it depends
16:19:52 <dcavalca> anyway, from our end, if this comes to pass during c8s the only reasonable approach I think is to maintain a coinstallable openssl3 package in hyperscale just for systemd
16:20:04 <dcavalca> as there's no way we can update the distro openssl
16:20:11 <dcavalca> and I don't want to rebuild half of centos for that
16:20:12 <Eighth_Doctor> well, we can ship openssl3 in EPEL
16:20:23 <dcavalca> ooh, that would be even better actually
16:20:32 <Eighth_Doctor> that kind of thing has been done before
16:20:37 <dcavalca> I hadn't thought about EPEL at all
16:20:45 <Eighth_Doctor> always think of EPEL :)
16:20:51 <dcavalca> Eighth_Doctor: do you think this will be coinstallable without too much trouble?
16:20:58 <Eighth_Doctor> yeah
16:21:11 <Eighth_Doctor> OpenSSL is a shitty package, but it's doable
16:21:31 <dcavalca> ok, I think we have a plan then
16:21:44 <Eighth_Doctor> once it lands in Rawhide, I'd be comfortable with us doing that
16:21:53 <dcavalca> I'll bring this up in the EPEL meeting later today as well to see how folks feel about it
16:21:59 <Eighth_Doctor> 👍️
16:22:07 <dcavalca> thanks Eighth_Doctor
16:22:07 <Eighth_Doctor> we'd obviously make the devel packages conflict and stuff
16:22:28 <dcavalca> #agreed tentative plan to add openssl3 to EPEL for compatibility with future systemd releases
16:22:50 <dcavalca> alright, anything else for announcements?
16:23:01 <dcavalca> oh, we have the VC hangout later today
16:24:37 <dcavalca> k, let's move to
16:24:40 <dcavalca> #topic Tickets
16:25:54 <dcavalca> for the qemu package for #67, there was some discussion yesterday, but we still need to figure out if we can build it in EPEL without conflicts
16:26:21 <bkircher> yes
16:26:38 <bkircher> What would the next step be? finish something up for initial review? Request an epel8 branch?
16:27:55 <dcavalca> yeah I think we need a branch to do any further work
16:28:12 <dcavalca> one of the existing maintainers of the package needs to request it
16:28:21 <dcavalca> or they need to add you as a co-maintainer so you can request it
16:28:33 <dcavalca> https://bugzilla.redhat.com/show_bug.cgi?id=1995353 is the ticket for that
16:29:19 <dcavalca> given the last comment by tdawson, there shouldn't be any policy blocker here
16:30:05 <bkircher> ok then, I'll answer with some initial findings with regards to the clashes in that RHBZ and kindly ask for a branch or so
16:30:40 <dcavalca> cool
16:30:50 <dcavalca> I don't think we have anything else for tickets this week
16:31:12 <dcavalca> #topic Membership
16:31:20 <dcavalca> don't think we have anything here either this round
16:31:27 <dcavalca> #topic Misc
16:31:32 <dcavalca> anything else folks wanna talk about?
16:38:46 <dcavalca> alright, let's end it early today then
16:38:53 <dcavalca> see you at the hangout later today
16:38:56 <dcavalca> #endmeeting