16:00:27 <dcavalca> #startmeeting Hyperscale SIG
16:00:27 <centbot> Meeting started Wed Feb 2 16:00:27 2022 UTC. The chair is dcavalca. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:27 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:33 <dcavalca> #chair dcavalca jvreeland
16:00:33 <centbot> Current chairs: dcavalca jvreeland
16:00:36 <dcavalca> morning folks
16:00:47 <anitazha> good morning
16:01:29 <dcavalca> let's wait a minute as usual for folks to join
16:01:31 <chantra> morning!
16:01:48 <themayor> ello ello ello
16:01:48 <davdunc> hello.
16:01:51 <salimma> morning all
16:01:59 <davdunc> \o themayor
16:02:14 <themayor> dealing with a broken second display so i may space in/out
16:02:27 <themayor> hey @davdunc
16:02:34 <davdunc> :)
16:02:49 <dcavalca> let's get started
16:02:59 <dcavalca> #topic Followups
16:03:22 <dcavalca> I've tagged a release for ethtool 5.16, and it looks like my MR to get it updated in c9s proper is making progress
16:03:58 <davdunc> cool!
16:04:05 <dcavalca> chantra: has an update on the rpm rebase and CoW
16:04:30 <Eighth_Doctor> hey
16:04:44 <chantra> yeah, I got RPM CoW to do some form of RPM signature validation. Threw a quick doc at https://hackmd.io/@chantra/BJ1Hedw0F
16:05:22 <chantra> it has the branches I work on on GH and the future SIG rpm PRs
16:05:41 <salimma> zstd: ours now have support for gz, xz and lz4 - the one in Fedora Rawhide too. the MR for getting that added to c9s is still open
16:06:53 <dcavalca> lemme get some of this in the minutes for posterity
16:07:18 <dcavalca> #info tagged a release for ethtool 5.16, c9s upstream MR in progress
16:07:39 <dcavalca> #info RPM CoW with signature validation update: https://hackmd.io/@chantra/BJ1Hedw0F
16:07:58 <dcavalca> #info zstd update with support for gz, xz and lz4
16:08:03 <chantra> plan for RPM CoW would be to test using hsx repo and work with upstream to sort out a path forward.
16:08:09 <salimma> MR for zstd: https://gitlab.com/redhat/centos-stream/rpms/zstd/-/merge_requests/4
16:08:40 <salimma> (it looks broken because of course we can't check in the new zstd tarball)
16:08:57 <Eighth_Doctor> zstd has been updated in the rhel kernel too
16:09:18 <Eighth_Doctor> https://gitlab.com/redhat/centos-stream/src/kernel/centos-stream-9/-/merge_requests/292
16:10:26 <dcavalca> lots of great work this week!
16:10:30 <dcavalca> anything else for followups?
16:11:22 <dcavalca> alright, let's move to
16:11:23 <dcavalca> #topic Announcements
16:11:48 <dcavalca> #info CentOS Dojo is starting tomorrow: https://wiki.centos.org/Events/Dojo/FOSDEM2022
16:11:58 <dcavalca> I'll have my usual SIG update talk there
16:12:05 <davdunc> awesome. will be there!
16:12:10 <dcavalca> which I still need to mostly write, so if there's stuff you want me to highlight lemme know :)
16:12:50 <dcavalca> on the systemd front, we're going to restart work on 250 and try to get it out in the next week or so
16:13:05 <dcavalca> and then we'll do 251 once that's released upstream
16:13:28 <themayor> i'll be talking about ELevate there too
16:13:34 <themayor> well myself and andrew ;)
16:13:39 <dcavalca> looking forward to that themayor
16:13:47 <davdunc> 👍
16:13:57 <salimma> I have my talk mostly written but the code needs to match the talk still :)
16:14:10 <salimma> themayor: ooh nice. I'll have lots of questions for that :)
16:14:12 * dcavalca has been abusing dnf distro-sync to test out c9s on preexisting c8s hosts
16:14:47 <dcavalca> anything else for announcements?
16:14:48 * salimma planning to get dnf system-upgrade working this year, unless it turns out ELevate is a better option
16:16:24 <dcavalca> moving on
16:16:25 <dcavalca> #topic Tickets
16:16:39 <dcavalca> I spent some time cleaning up the tracker and filing tickets for stuff we need to do
16:16:51 <dcavalca> if you're bored, feel free to pick something up that's not currently assigned
16:17:23 <dcavalca> bkircher: any update on the qemu stuff for #67?
16:17:35 <Eighth_Doctor> system upgrade would be great
16:17:52 <bkircher> dcavalca, sorry not much
16:18:00 <bkircher> still using COPR here
16:18:41 <dcavalca> no worries
16:19:06 <dcavalca> jvreeland, Eighth_Doctor: for the kernel work in #7, do we plan to update c8s to 5.14 ?
16:20:10 <Eighth_Doctor> yes
16:20:38 <Eighth_Doctor> jvreeland is working on it, iirc
16:21:02 <dcavalca> cool; I'm starting to replace our internal homegrown build of perf with the hyperscale one
16:21:03 <jvreeland> Yes! I have it building just need to finish testing and make the Linux branch I had originally more like the current c9s branch instead of having a split centos-sig target. Should have builds in cbs later today.
16:21:17 <salimma> woot
16:22:17 <dcavalca> awesome, thanks jvreeland
16:22:17 <Eighth_Doctor> sweet
16:22:27 <Eighth_Doctor> I'm also working on turning my rebase work into some scripts
16:22:41 <Eighth_Doctor> so we can continuously validate new builds against new commits in the c9s kernel
16:22:50 <dcavalca> oh we should hook that up in OpenShift
16:23:11 <davdunc> dcavalca: I would like to walk through how you do that!
16:23:14 <Eighth_Doctor> basically, I think it's going to work out that I'm the primary maintainer for c9s, while jvreeland maintains c8s
16:23:30 <dcavalca> Eighth_Doctor: sounds like a plan
16:23:53 <Eighth_Doctor> obviously we can trade-off as needed once everything is in place, but I think that's how things are going to work out
16:23:59 <dcavalca> davdunc: you'll wanna start by requesting access, lemme find the last ticket we filed for that so you can copy it
16:24:13 <davdunc> thanks.
16:25:25 <dcavalca> davdunc, https://pagure.io/centos-infra/issue/345
16:25:46 <dcavalca> the CI folks also hang out in #centos-ci if you need help
16:26:10 <davdunc> They are most helpful. I'll make the request and then we can jump in.
16:26:24 <dcavalca> sounds good
16:26:38 * dcavalca would love some help to get buildah running under openshift so we can do container builds there
16:27:22 <dcavalca> I think that's all for tickets
16:27:24 <dcavalca> let's go to
16:27:27 <dcavalca> #topic Membership
16:27:33 <Eighth_Doctor> yeah, we need to get c9s containers going soon
16:27:44 <dcavalca> we have one membership request in #97 from daandemeyer
16:27:53 <dcavalca> daandemeyer, wanna introduce yourself to the group?
16:28:38 <daandemeyer> Hey everyone! I'm Daan De Meyer, a colleague of Davide at Meta working on systemd. I'll be helping out with the sig systemd repo.
16:28:51 <davdunc> welcome daandemeyer
16:29:10 <bkircher> Welcome :)
16:29:12 <dcavalca> any objections to Daan joining the sig?
16:29:15 <salimma> woohoo
16:29:29 <salimma> (that's a no to objection)
16:29:42 <davdunc> afaiac that's one more mentor!
16:30:23 <Eighth_Doctor> no problem from me
16:30:33 <Eighth_Doctor> (we're easily the biggest SIG now, I think?)
16:30:49 <dcavalca> I haven't ran the numbers but I wouldn't be surprised
16:30:58 <dcavalca> we've definitely more than doubled in size since the start
16:31:23 <dcavalca> #agreed welcome daandemeyer to the hyperscale SIG
16:31:23 <oidoming> Hello my name is Oscar, I would like to join I work at Intel with Tomasz and we plan to contribute :)
16:31:36 <dcavalca> I'll take care of your paperwork later today
16:32:16 <davdunc> this is awesome having so many people participating.
16:32:30 <dcavalca> hi oidoming and welcome, are there some areas in particular you're interested in working on?
16:33:03 <Eighth_Doctor> hey oidoming
16:33:17 <Eighth_Doctor> (who is Tomasz?)
16:33:18 <oidoming> CI/CD stuff and also I'm open to anything
16:34:49 <salimma> hi oidoming
16:35:57 <dcavalca> Eighth_Doctor: Tomasz Paszkowski I assume, also from Intel; we've been talking to them from the Meta side of the world
16:36:04 <dcavalca> any objections to oidoming joining?
16:36:26 <salimma> nope. +1 to joining
16:36:34 * Eighth_Doctor shrugs
16:36:38 <Eighth_Doctor> +1 to joining
16:37:02 <Eighth_Doctor> (I don't know either of these people, but I don't see a problem with them joining)
16:37:20 <jvreeland> +1 here too
16:37:23 <anitazha> +1
16:39:03 <dcavalca> I'm also +1 in case it wasn't clear
16:39:13 <dcavalca> #agreed welcome oidoming to the hyperscale SIG
16:39:31 <dcavalca> I'll also take care of your paperwork later today
16:39:36 <oidoming> thanks!
16:39:51 <dcavalca> anything else for membership?
16:41:17 <davdunc> silence equals completion I guess.
16:41:36 <dcavalca> yup
16:41:39 <dcavalca> #topic Misc
16:41:45 <Bahhumbug> (Reminder: centos/hyperscale cloaks are available to SIG members; either contact me directly or have dcavalca do so and I'll take care of it)
16:41:55 <dcavalca> I have one last thing, which is mostly a heads up for jvreeland and djohansen
16:42:09 <dcavalca> there's some interest on our side in trying out rasdaemon as an alternative to mcelog
16:42:16 <dcavalca> and folks are beginning to experiment with that
16:42:43 <dcavalca> so you might see some activity there and/or bug reports down the road
16:43:39 <jvreeland> Sounds good
16:44:25 <Eighth_Doctor> I've also updated our ticket trackers to have c8s and c9s labels
16:44:41 <Eighth_Doctor> please use them when categorizing reports so that we know where they apply
16:45:50 <dcavalca> thanks Eighth_Doctor
16:47:45 <dcavalca> oidoming: I've filed https://pagure.io/centos-sig-hyperscale/sig/issue/98 to track your onboarding
16:48:04 <dcavalca> daandemeyer: we'll use https://pagure.io/centos-sig-hyperscale/sig/issue/97 that you'd already filed
16:49:27 <dcavalca> I think that's all for this week
16:49:33 <dcavalca> thanks everyone for joining
16:49:38 <salimma> thanks dcavalca
16:49:47 <dcavalca> hope to see you tomorrow at Dojo
16:49:55 <dcavalca> #endmeeting