16:00:16 <davide> #startmeeting Hyperscale SIG
16:00:16 <centbot> Meeting started Wed Jun  8 16:00:16 2022 UTC.  The chair is davide. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:16 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:39 <davide> uh... is the bot working?
16:00:41 <davide> ah here we go
16:00:54 <davide> #chair dcavalca jvreeland
16:00:54 <centbot> Current chairs: davide dcavalca jvreeland
16:00:59 <davide> morning folks
16:01:03 <aekoroglu> morning
16:01:05 <jvreeland> morning
16:01:16 <oidoming> morning
16:03:21 <davide> let's get started
16:03:26 <davide> #topic Followups
16:03:48 <davide> anything from the last meeting we should cover?
16:03:55 * davide is trying to find the minutes
16:05:52 <davide> ah found it: https://centbot.centos.org/minutes/2022/May/centos-meeting.2022-05-25-16.00.html
16:06:23 <davide> aekoroglu: looks like you had an action to write up the SIG chair election process
16:06:44 <michel> Hello
16:07:13 <djohansen> Good morning
16:07:59 <aekoroglu> it seems ok but what do you think ? its good to use rcv bytheway
16:08:22 <aekoroglu> https://pagure.io/centos-sig-hyperscale/sig/issue/112
16:08:36 <davide> yeah that lgtm
16:09:14 <davide> do we want to allow for private nominations? I don't personally care much, but it's something I've seen discussed in other context
16:09:24 <davide> as folks might be shy to publicly nominate themselves
16:10:26 <davdunc[m> they might, but I want them to overcome the urge to do thinigs in secret.
16:10:44 <davide> yeah that's fair
16:10:47 <aekoroglu> +1
16:11:05 <jvreeland> +1
16:11:34 <davide> I'm +1 as well for clarity
16:11:44 <davdunc[m> I would rather encourage self-nomination
16:12:13 <davide> also, who actually runs the election? we don't have a secretary role at the moment
16:12:28 <davide> I'm fine doing it, but this may also be worth formalizing at some point
16:12:45 <davide> also to avoid (the appearance of) conflicts of interest and stuff
16:12:52 <aekoroglu> in Fedora its like "Nominees are requested to answer the selected questions using a private issue in Pagure."
16:13:01 <davdunc[m> makes sense to formalize it......
16:13:37 <davdunc[m> it being the secretary role.
16:14:01 <davide> should we do a vote for the secretary first, and then have them run the vote for the open chair?
16:14:31 <davide> I don't want to add too much process as this is a pretty small group, but otoh it's good to have very clear policies around this stuff
16:15:10 <michel> Do we have examples of fedora SIGs or WGs with secretaries?
16:15:27 <michel> So we don't reinvent the wheel
16:15:27 <michel> Trying to remember if Workstation has one
16:15:44 <davide> to be clear, secretary == the person that makes the ballot and tablulates results in this context
16:16:00 <davdunc[m> that's the PM in every case for Fedora elections, no?
16:16:11 <davide> in the general sense, a secretary would also run meetings, ensure minutes exist, etc, but I don't think we necessarily need to formalize that for this group
16:16:23 <davide> unless someone wants to do it of course
16:16:39 <michel> https://docs.fedoraproject.org/en-US/workstation-working-group/governance/
16:17:24 <michel> We can also just nominate someone to run this on a case by case basis
16:17:48 <davdunc[m> that sounds like a great way to do it. Michel Alexandre Salim
16:18:15 <davide> yeah, I'm ok with that; wanna write it up in the issue for the record?
16:19:19 <davide> I'm happy to do it for this round (as I wouldn't be on the ballot anyway)
16:20:09 <davdunc[m> Davide Cavalca: that question was open ended on who should write it up?
16:20:33 <davide> oh I meant Michel Alexandre Salim as he was the one that proposed it, but it can be a group effort
16:20:53 <davdunc[m> got it.
16:21:16 <davide> I mostly just want this formalized so we don't need to spend time on it again the next time a seat is open
16:21:42 <davide> and also to hopefully help other SIGs that might have similar issues
16:22:09 <davide> so, to recap
16:22:30 <davide> we'll hold an election to fill the chair seat vacated by jvreeland
16:23:04 <davide> we'll have nominations 8-15, voting 15-22
16:23:13 <davide> I'll act as secretary for this election
16:23:40 <davide> any comments / objections / etc on this plan?
16:25:31 <michel> I can write this up but this might trip over aekoroglu:
16:25:39 <aekoroglu> its good and I could help if needed
16:25:42 <davdunc[m> I think it's a good plan.
16:27:08 <davide> #agreed chair election nominations 8-15, voting 15-22, dcavalca will act as secretary, https://pagure.io/centos-sig-hyperscale/sig/issue/112 for details
16:27:13 <davide> thanks folks
16:27:21 <davide> anything else for followups?
16:28:45 <davide> #topic Announcements
16:29:06 <davide> I've built and tagged a new kpatch version yesterday
16:29:28 <davide> also, there's a centos board meeting this afternoon if folks are interested
16:29:44 <davdunc[m> good to know on both accounts.
16:30:27 <chantra> I have had some feedback on RPM CoW implementation from Panu. https://github.com/rpm-software-management/rpm/discussions/2057 I still have to parse and think through it, but at least there is motion and hint in which direction this could take.
16:30:55 <davide> we're also getting an updated Pagure for git.centos.org
16:31:06 <davide> which means we should soon be able to have a working PR workflow for code review
16:31:14 <davide> that should make it easier for folks to collaborate and contribute
16:31:15 <chantra> \o/
16:31:33 <arrfab> well, it need "some love" as we need to grant group commit access but doable
16:31:46 <davide> baby steps :)
16:31:49 <arrfab> have already an idea about how to do that at the centos side, without an infra ticket
16:32:13 <arrfab> basically a git repo with PR and once merged a script would call pagure api to reflect changes
16:32:16 <davide> happy to help test stuff out if needed, just let us know
16:32:24 <arrfab> so like creating new project and granting commits rights
16:32:34 <arrfab> yeah, but multiple moving pieces in the infra
16:32:53 <arrfab> initially I was hoping that the new "collaborator" feature in pagure 5.13 was working but no
16:33:23 <davide> that's too bad, is there something we should report to pagure upstream?
16:33:35 <arrfab> davide: already ticket open for this ;-)
16:33:49 <davide> ah perfect
16:34:02 <arrfab> but when it will be available we can give it a quick test and then update without waiting for RH EXD team to validate, as it will be minor update on same RHEL version
16:34:39 <davide> sounds good, thanks arrfab
16:35:00 <davide> anything else for announcements?
16:35:42 <arrfab> davide: there will be some changes for centos ci infra too, but all that will be explained also next week at centos dojo ;-)
16:36:09 <davide> good to know, looking forward to the Dojo
16:36:25 <davide> I should probably write my Dojo talk too :)
16:36:40 <aekoroglu> :)
16:37:17 <davide> alright, let's move to
16:37:20 <davide> #topic Tickets
16:39:00 <davide> I've just filed https://pagure.io/centos-sig-hyperscale/sig/issue/115 to get the missing minutes added to the page
16:39:14 <davide> we already talked about the election stuff
16:39:19 <davide> anything else here that we should discuss?
16:40:43 <Eighth_Doctor> oh hai
16:40:49 <Eighth_Doctor> I forgot about this until just now
16:41:01 <Eighth_Doctor> my talk for devconf.us has been accepted
16:41:09 <davide> excellent
16:41:11 <Eighth_Doctor> so that means if we have a dojo for devconf.us, we should do something there
16:41:13 <aekoroglu> perfect
16:41:36 <davide> I believe the plan is to have a Dojo, but I don't think it's been formally announced yet
16:42:04 <Eighth_Doctor> I
16:42:04 <Eighth_Doctor> we should talk to shaun about getting one set up for devconf.us then
16:42:10 <davide> yeah, I'll followup with him
16:42:36 <Eighth_Doctor> excellent
16:42:36 <davide> iirc there was also some discussion of doing an in-person board meeting at the same event, but I haven't caught up on this yet
16:42:57 <Eighth_Doctor> F2F board meeting would be a good idea
16:43:05 <Eighth_Doctor> the one I had prior to oSC for the openSUSE Board was really fruitful
16:43:19 <Eighth_Doctor> I imagine it might be helpful for the CentOS board to do something similar
16:43:40 <davide> happy to try and organize a hackfest of something for Hyperscale if there's interest
16:44:16 <davide> either leveraging the conference venue, or some space nearby
16:44:26 <Eighth_Doctor> that would be great actually
16:44:41 <Eighth_Doctor> we haven't done one ever and I think it'd be fun to do one
16:44:46 <davide> yeah, agreed
16:46:14 <davide> #topic Membership
16:46:24 <davide> I don't think we had anything for this
16:46:35 <davide> #topic Misc
16:47:14 <davide> one last thing I wanted to bring up: I'm starting to provision some test resources internally on IBM Cloud for ppc64le and s390x, and have noticed we don't have CentOS Stream images published there
16:47:48 <davide> I can make custom images, but if anybody's interested in trying to have real ones lemme know, happy to join forces
16:48:28 <davide> and down the road it's obviously be nice to also have Hyperscale cloud images there, once we start publishing those
16:50:19 <davide> anything else for the last 10 minutes?
16:50:45 <aekoroglu> I'll add simdjson into Fedora/EPEL but I think facebook+twitter might be interesting with that too I'm think will be good to have simdjson in hyperscale ?
16:50:52 <aekoroglu> https://simdjson.org/
16:51:18 <davide> aekoroglu: if it's going to be in EPEL, it'll be available for Hyperscale already, as we depend on EPEL
16:52:00 <davide> didn't know about this library, looks useful
16:52:51 <aekoroglu> new avx-512 support boosts performance between 25% to 40%
16:53:34 <davide> nice
16:54:47 <michel> oh, IBM Cloud has s390x? nice
16:55:16 <davide> yeah, on VPC (though I haven't managed to get one to provision successfully yet)
16:59:58 <davide> I think that's all for this week
17:00:14 <davide> thanks for joining folks, enjoy the rest of your day
17:00:19 <davide> #endmeeting