16:00:34 <davide> #startmeeting Hyperscale SIG
16:00:34 <centguard> Meeting started Wed Jun 22 16:00:34 2022 UTC. The chair is davide. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:34 <centguard> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:34 <centguard> The meeting name has been set to 'hyperscale_sig'
16:01:19 <michel> Hello
16:01:28 <davide> #chair dcavalca jvreeland
16:01:28 <centguard> Current chairs: davide dcavalca jvreeland
16:01:34 <davide> morning everyone
16:01:43 <oidoming> morning
16:02:08 <aekoroglu> morning
16:02:33 <DaanDeMeyer[m]> Good morning
16:03:46 <davide> let's get started
16:03:47 <davide> #topic Followups
16:04:35 <davide> #info Summer Dojo hyperscale SIG update video is out: https://www.youtube.com/watch?v=P5vMYIjzWOY
16:05:04 <davide> also speaking of dojo, we should decide when to do the SIG meetup for the August one
16:05:25 <davide> Shaun is going to help us get a room at the venue, but we need to pick a day and have a rough count of people coming
16:06:11 <davide> for context, Dojo is the 17th, Devconf is 18th-20th
16:06:27 <michel> Do we assume mostly people here, or lots of interested people too?
16:06:54 <davide> I'd expect mostly people here plus a few interested folks that happen to be around
16:06:55 <davide> it also depends on when we do this
16:07:02 <davide> if we do it on say the 16th, I'd expect it'd be mostly us
16:07:11 <davide> if we do it overlapping with devconf, we might get more guests
16:07:39 <davide> this would also be easier if the devconf schedule were out already, but alas it is not
16:09:42 <michel> Who's planning devconf, can we ask for the schedule?
16:10:15 <davide> not sure, but either way we need to made a decision today
16:10:34 <davide> otherwise it'll be tricky to get meeting space sorted out
16:11:05 <davide> if folks are ok coming a day earlier, I'm leaning towards doing this on the 16th and just asking for a full day room
16:13:38 <michel> I'm abstaining since I can't come
16:13:39 <davide> also, if you haven't booked yet and wanna stay at the hotel near the venue, I recommend doing so now as it seemed to be filling up fast
16:16:23 <davide> so... if you have opinions on this, please speak up, otherwise I'll just make an executive decision and pick something :)
16:17:36 <DaanDeMeyer[m]> I don't have a preference :)
16:17:53 <anitazha> I missed a critical part of the conversation. What are we giving opinions on?
16:18:31 <davide> oh sorry, this was about the SIG meetup we wanted to organize alonside the August Dojo/Devconf thing
16:18:48 <davide> as a bunch of folks had expressed interest in the past in meeting in person and doing a thing there
16:19:33 <anitazha> Oh yes I like this idea of a SIG meet at those events
16:20:01 <davide> so, Dojo is the 17th and devconf is 18-20
16:20:15 <davide> the idea I was suggesting was to do this on the 16th and just get a room for the full day
16:20:37 <davide> as the devconf schedule isn't out yet so it's hard to plan for something overlapping there
16:21:10 <anitazha> I like that. I might not stay for all of devconf so meeting before is good
16:22:00 <davide> alright, I'll tell Shaun to go with that and get a room for... 20 people I guess? that's probably enough
16:22:39 <davide> and once that's locked in I'll email centos-devel so folks know this is a thing in case they wanna come
16:23:16 <davide> #agreed in-person Hyperscale meetup in Boston on Aug 16 (before Dojo/Devconf)
16:23:34 <davide> so, the only other followup I had was the election to fill jvreeland's chair
16:24:02 <davide> but given that we haven't had any formal nominations for that, I think we should punt for another week
16:24:10 <michel> We should make sure Ben Cotton knows too so it's added to his Friday reports, he lists conference events too
16:24:18 <davide> if nobody self nominates I'll just volunteer someone :)
16:24:31 <davide> oh good call, thanks for the reminder
16:24:36 <davide> anything else for followups?
16:25:36 <davide> alright, moving on
16:25:41 <davide> #topic Announcements
16:25:50 <davide> #info SIG quarterly report is due by July 4
16:26:00 <davide> I'll try and get a draft started this week
16:26:26 <davide> I had a couple more minor things
16:26:53 <davide> our perf package is currently uninstallable thanks to modularity, so I'm working with Conan Kudo to get it rebuilt without perl support: https://pagure.io/centos-sig-hyperscale/package-bugs/issue/18
16:28:18 <davide> also, we're considering reverting the "rpmdb defaults to ndb" for c8s in experimental, as we've noticed some pretty unpleasant issues
16:28:37 <davide> e.g. if your rpm packages accidentally get switched to the upstream one, the rpmdb isn't readable anymore
16:28:58 <davide> chantra was exploring options here
16:29:08 <davide> that's all I had, anything else for announcements?
16:32:12 <Eighth_Doctor> yeah, let's not do ndb anymore
16:32:22 <Eighth_Doctor> c9s is already going to use sqlite anyway
16:32:30 <aekoroglu> +1
16:32:37 <davide> yeah, this isn't an issue for c9s luckily
16:33:13 <Eighth_Doctor> I'm thinking of moving the linux repo to gitlab.com/CentOS/Hyperscale
16:33:31 <Eighth_Doctor> because it's freakishly big and slow
16:33:36 <Eighth_Doctor> and while it's big and slow on GitLab too, it's... less so
16:33:56 <davide> yeah, it took a good 20 min to clone it yesterday, and about the same time for pagure to fork it...
16:34:25 <Eighth_Doctor> this is not changing our overall usage of pagure.io/centos-sig-hyperscale, but our maintenance strategy makes that repo even bigger because we're tracking all our updates with rebase strategy instead of merges
16:34:41 <Eighth_Doctor> and we're doing it that way because we want to track and reduce our delta whenever possible
16:35:27 <Eighth_Doctor> other similarly large src repo forks might get the same treatment in the future
16:35:34 <Eighth_Doctor> thankfully we don't have any others that freakishly big
16:36:09 <davide> I think that's fine, we'll just need to file an infra ticket to request the namespace
16:36:19 <DaanDeMeyer[m]> mkosi 13 is out with --repository-directory so the stable release can build hyperscale packages now for those who are interested in that
16:36:26 <Eighth_Doctor> neat
16:36:32 <davide> oh that's great
16:36:33 <Eighth_Doctor> livecd-tools may gain something similar, actually
16:36:42 <Eighth_Doctor> https://github.com/livecd-tools/livecd-tools/pull/240
16:36:49 <DaanDeMeyer[m]> *images not packages
16:37:06 <Eighth_Doctor> anyone interested in the change, I would encourage testing
16:37:09 <Eighth_Doctor> and giving feedback
16:39:00 <Eighth_Doctor> Davide Cavalca: could you request the GitLab.com/CentOS/Hyperscale namesapce?
16:39:16 <davide> sure, I'll file a ticket
16:39:16 <Eighth_Doctor> thanks
16:39:26 <Eighth_Doctor> make sure you and I are able to manage the namespace at the minimum
16:39:58 <Eighth_Doctor> Davide Cavalca: btw, I'm happy to nominate myself for co-chair of the SIG
16:40:17 <Eighth_Doctor> at this point, I do a lot of de facto leadership anyway
16:40:25 <davide> yay, thanks Conan Kudo
16:40:30 <Eighth_Doctor> might as well be listed as a de jure leader if everyone wants
16:40:50 <davide> we'll give it till the end of the week and then either hold an election, or make it official if you end up being the only one
16:40:56 <Eighth_Doctor> sounds good
16:41:06 <davide> mind filing a ticket in the meantime to there's a record for it?
16:41:10 <Eighth_Doctor> sure
16:41:11 <davide> * so
16:42:35 <aekoroglu> count me as backup :)
16:42:39 <davide> filed the gitlab namespace request: https://pagure.io/centos-infra/issue/822
16:43:19 <davide> aekoroglu: please also file a ticket if you'd like to self-nominate so we have it on the record
16:43:50 <aekoroglu> I'll do as backup then :)
16:44:21 <davide> sounds good
16:44:24 <davide> alright, moving over to
16:44:26 <davide> #topic Tickets
16:44:49 <davide> after the perf debacle, I've filed https://pagure.io/centos-sig-hyperscale/sig/issue/119 to hopefully catch this kind of stuff down the road
16:45:11 <davide> if anybody wants to work on it feel free to take it, otherwise I'll try to cook something up in the coming month or so
16:46:10 <michel> davide: We can probably use tdawson's will-it
16:46:10 <davide> oidoming put up a PR for https://pagure.io/centos-sig-hyperscale/sig/issue/91 at https://pagure.io/centos-sig-hyperscale/containers-releng/pull-request/4
16:46:20 <davide> I haven't had a chance to review this yet
16:46:42 <davide> oh I hadn't thought of that, mind adding a comment to the ticket so we don't forget?
16:46:51 <Eighth_Doctor> btw, done: https://pagure.io/centos-sig-hyperscale/sig/issue/120
16:46:57 <Eighth_Doctor> nomination ticket ^
16:47:10 <michel> davide: Will do
16:47:32 <davide> thanks, and thanks :)
16:47:43 <Eighth_Doctor> there's also the repoclosure scripts from releng we could adapt?
16:48:15 <davide> didn't know about that one
16:48:15 <Eighth_Doctor> e.g. spam-o-matic: https://pagure.io/releng/blob/main/f/scripts/spam-o-matic
16:48:55 <davide> oh yeah that looks useful too
16:49:24 <Eighth_Doctor> added to the ticket as a comment
16:49:29 <davide> thanks
16:49:31 <davide> anything else for tickets?
16:51:12 <davide> guess not
16:51:15 <davide> #topic Membership
16:51:23 <davide> nothing here for this week I think?
16:51:49 <davide> #topic Misc
16:52:02 <davide> anything else for the last few minutes?
16:55:27 <davide> alright, I guess that's it then
16:55:34 <davide> thanks everyone for coming, and see y'all soon
16:55:37 <davide> #endmeeting