16:00:53 <salimma> #startmeeting Hyperscale SIG
16:00:53 <centbot> Meeting started Wed May 25 16:00:53 2022 UTC. The chair is salimma. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:53 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:01:21 <salimma> #chair salimma
16:01:21 <centbot> Current chairs: salimma
16:02:11 <salimma> anyone around? Eighth_Doctor Conan Kudo daandemeyer davdunc chantra_
16:02:17 <Eighth_Doctor> yes
16:02:20 <Eighth_Doctor> I'm here
16:02:23 * kcwells waves
16:02:35 <salimma> hi kcwells !
16:03:23 <salimma> let's wait a bit, then we can go to follow-ups. Davide's on PTO, he'll be back for the next meeting
16:03:52 <aekoroglu> Hi salimma + Eighth_Doctor + kcwells :)
16:04:01 <salimma> hi aekoroglu !
16:04:13 <salimma> ok, let's get started then
16:04:15 <salimma> #topic Followups
16:04:49 <salimma> uh, we've been remiss in adding the logs to the SIG website (last is from 03-30)... anyone has a follow up from last meeting?
16:04:54 <salimma> otherwise I'll go by the list of open issues
16:06:46 <salimma> Conan Kudo: I don't see chantra_ yet but this is a Pagure question so we can probably discuss it
16:06:51 <salimma> https://pagure.io/centos-sig-hyperscale/sig/issue/114
16:07:35 <Eighth_Doctor> that's more of a thing we'd need to make to respect some kind of string format
16:07:46 <salimma> this is only possible if we have a dist-git like set up, I think? issue and commit in the same repo
16:07:58 <Eighth_Doctor> I typically use `pagureio#<project>#<issuenumber>
16:08:01 <Eighth_Doctor> s/>/>`/
16:08:04 <salimma> oh, is that already supported?
16:08:08 <Eighth_Doctor> nope
16:08:16 <salimma> ah
16:08:21 <Eighth_Doctor> pagure itself supports fully qualified URLs
16:08:36 <Eighth_Doctor> but dist-git is on a separate pagure instance from where those issues are
16:08:38 <Eighth_Doctor> so you need something to ferry actions
16:08:58 <salimma> plus also... ideally committing is not enough right?
16:08:58 <Eighth_Doctor> e.g. an MQTT listener that goes and does something on pagure.io
16:09:08 <salimma> we want the issue to close when we detect a build. similar to how we have Bodhi<->Bugzilla integration
16:09:22 <Eighth_Doctor> right, but that's harder to pull off
16:09:36 <Eighth_Doctor> since Koji doesn't send messages with the needed info there
16:09:42 <salimma> #info https://pagure.io/centos-sig-hyperscale/sig/issue/114 - discussing how to link updates to Pagure issues
16:09:56 <Eighth_Doctor> actually mechanically closing issues when they're mentioned isn't hard
16:10:01 <Eighth_Doctor> the problem is how to get the info to make the action
16:10:03 <salimma> yeah... I think linking it to commit is better than nothing, though Manu specifically asked about 'when updates pushed'
16:10:11 <salimma> oh, did oidoming say he's going to work on it?
16:10:21 <Eighth_Doctor> "when updates pushed" is impossible
16:10:41 <salimma> right. well, impossible until we have something like bodhi
16:10:53 <oidoming> yeah I'm gonna work on it
16:10:56 <salimma> actually... that just means integrating with CBS, right?
16:11:02 <salimma> since our 'push' is tagging a build
16:11:08 <salimma> hi oidoming !
16:11:24 <oidoming> I think fedora message could be used to get notified when a cbs build is made?
16:11:29 <Eighth_Doctor> pagure MQTT messages on git.centos.org should include commit messages for pushes
16:11:44 <Eighth_Doctor> none of that stuff is wired into Fedora AMQP stuff
16:11:53 <Eighth_Doctor> CentOS uses MQTT, not AMQP
16:11:57 <salimma> ah, the messaging migration strikes again
16:12:09 <Eighth_Doctor> yup
16:12:19 <salimma> remind me.. in Fedora land which came first? they're moving from mqtt to amqp, right?
16:13:20 <salimma> let's discuss this for a few more minutes, and then we can move on to the election process
16:13:46 <Eighth_Doctor> Fedora used ZeroMQ before
16:13:46 <Eighth_Doctor> moved to AMQP today
16:13:49 <salimma> I wonder if jvreeland is still around
16:13:53 <Eighth_Doctor> CentOS has always used MQTT
16:14:25 <salimma> why... does Fedora not just use MQTT?
16:15:00 <jvreeland> I am still around
16:15:19 <salimma> hola Justin!
16:15:24 <Eighth_Doctor> Michel Alexandre Salim 🎩: I don't know, everything is a mess
16:15:24 <salimma> #chair jvreeland
16:15:24 <centbot> Current chairs: jvreeland salimma
16:15:48 <salimma> we can discuss how to elect your replacement :)
16:16:17 <salimma> when Davide is back maybe he can bring it up to the board - maybe there needs to be better integration here between the two
16:16:48 <jvreeland> Sounds good to me : )
16:16:58 <salimma> anything else for the current issue (how to make update pushes close issues)?
16:18:47 <salimma> alright then
16:19:00 <salimma> #info https://pagure.io/centos-sig-hyperscale/sig/issue/112 SIG chair election process
16:19:30 <salimma> Davide put up a proposal 13 days ago and there's no comment yet, I'll let everyone read it for a few minutes (esp the link to RCV)
16:20:30 <kcwells> Nice, ranked-choice voting
16:20:35 <salimma> I personally like ranked choice better than the approval voting Fedora uses or the convoluted Debian Condorcet voting process that I don't understand :P
16:20:50 <salimma> yeah. approval will be OK with many voters, but in a small field what if we get ties
16:21:30 <salimma> any objection to either the voting method proposed, or the schedule? with 1 week + 1 week we can basically decide to call an election in one meeting and wrap it up in the next
16:23:19 <jvreeland> all sounds good to me
16:23:25 <aekoroglu> +1
16:23:48 <kcwells> Was gonna mention it in the Opens, but I'll be on PTO the month of June, but this just requires internet access to cast a vote, right?
16:23:48 <salimma> I'm +1 too
16:24:05 <kcwells> So I could theoretically do it from my cell phone wherever I am
16:24:28 <salimma> yeah, you just need to cast a vote on the ticket we open and comment +1 - at least that's how voting normally works in SIGs
16:24:36 <aekoroglu> you should be @ the office mate, no vacation excuse :)
16:24:59 <kcwells> aekoroglu: 🤣
16:25:04 <salimma> now now, I'm looking forward to taking a month-long vacation too, I just need to wait until I don't have an intern :)
16:25:06 <kcwells> salimma: sounds good
16:25:27 <salimma> anyone else? we're up to +4 now
16:25:44 <salimma> Conan Kudo and oidoming ?
16:26:13 <oidoming> +1 :)
16:26:18 <salimma> after this I guess we find a volunteer to actually write this up
16:27:08 <salimma> while waiting for Conan Kudo - anyone from Intel interested in running?
16:27:35 <salimma> it's not official, but ideally we have representation from multiple companies
16:27:46 <salimma> or someone from Twitter too
16:30:48 <salimma> calling it +5/0/+1 unless I miscount
16:31:09 <salimma> who wants to write this up?
16:31:38 <Eighth_Doctor> +1
16:32:01 <salimma> I volunteer to write this up, unless anyone else wants to
16:32:04 <djohansen> +1
16:32:11 <aekoroglu> I would love to help too
16:32:36 <salimma> oh sweet. aekoroglu I'll assign the issue to you then
16:32:54 <aekoroglu> Yup
16:33:06 <salimma> #agreed election timeline and mechanism as proposed in #112
16:33:19 <salimma> #action aekoroglu to write up the SIG chair election process
16:34:34 <salimma> those are the only two issues that have updates. any update on the rest?
16:35:14 <salimma> and I guess I just accidentally combined followups and tickets.. so.
16:35:18 <salimma> #topic Announcements
16:35:28 <salimma> anyone has anything to announce?
16:35:33 * Eighth_Doctor shrugs
16:36:04 <salimma> is RHEL 9 out yet? :)
16:36:28 <Eighth_Doctor> yes
16:36:45 <Eighth_Doctor> it's available for download now
16:37:02 <salimma> sweet. must be quite new, Alma is not done yet
16:37:29 <Eighth_Doctor> yeah
16:37:53 <Eighth_Doctor> I also asked CentOS infra for RHEL 9 buildroots for kmods sig
16:38:01 <Eighth_Doctor> https://pagure.io/centos-infra/issue/786
16:38:32 <salimma> and EPEL probably has switched over right? I think it was discussed last week
16:38:53 <Eighth_Doctor> yes
16:39:07 <Eighth_Doctor> that's already done
16:39:55 <salimma> going forward, one interesting question will be... how long do we keep up Hyperscale 8
16:40:51 <salimma> but that's still a long time away, I guess. our servers are still overwhelmingly Stream 8
16:41:15 <salimma> any other announcement?
16:41:58 <aekoroglu> stay away from modularity in copr :)
16:42:44 <salimma> ah... why, did you try it? :)
16:42:49 <salimma> I try to stay away from modularity, full stop
16:43:54 <aekoroglu> I did unfortunately :)
16:44:14 <Eighth_Doctor> we'll probably drop Stream 8 as soon as your production deployments of Stream 9 start
16:45:15 <salimma> well.. unless we have external users by then
16:45:23 <aekoroglu> does anyone know something about timing or roadmap etc ?
16:45:35 <salimma> but yeah I anticipate at some point we might need an EOL policy or somethign like Fedora's stable updates policy
16:45:46 <salimma> Stream 8 will be EOLed in.. May or June 2024
16:47:08 <salimma> moving on, it's this time already
16:47:14 <salimma> #topic Misc
16:47:36 <salimma> kcwells: enjoy your PTO!
16:48:22 <kcwells> Haha, thanks! Visiting friends and family. First time going "back home" in 7.5 years
16:48:34 <salimma> oh wow. must be far
16:48:54 <kcwells> 2.8k miles says google
16:49:31 <salimma> not quite coast to coast but close :)
16:50:10 <kcwells> OR to PA, so the states technically border the two oceans
16:50:11 <kcwells> haha
16:51:15 <salimma> ah. yeah I'm flying from Seattle (a bit northwest) to Chicago this weekend, and that's already 2k miles!
16:53:00 <salimma> if there's nothing else... that's it all
16:53:08 <salimma> thanks everyone for coming and participating!
16:53:11 <kcwells> (The internet tells me that PA technically just borders the Deleware river that feeds into the Atlantic, so apparently my memories of 4th grade state geography are wrong.)
16:53:43 <kcwells> s/deleware/delaware/. Proving my point.
16:53:44 <salimma> oh true. it's Maryland that's by the coast
16:53:54 <aekoroglu> :)
16:54:01 <salimma> deleware sounds like software that would delete random shit from your machine
16:54:11 <salimma> #endmeeting